Google
  Web www.spinics.net

Re: Xorg CPU consumption extremely high

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Wed, 18 Jul 2012 23:34:45 +0200, Nikos Kasioumis <kasioumis@xxxxxxxxx> wrote:
> As soon as I log into Gnome and open Google Chrome (for example) just to
> open a new tab or switch from one tab to the other the CPU consumption of
> Xorg (as observed in top) goes up to 70%, 80% or even 90%. The system
> becomes unresponsive for about a second and then the CPU usage of Xorg
> drops to more normal levels again (<10%). This happens with other simpler
> applications too such as gnome-terminal (opening new tabs, switching tabs,
> etc). Needless to say it's impossible to use the system like that.

If you install the debug symbols for your packages and run perf record
whilst you login. The hottest functions in that profile will give us a
probably cause for why it is so slow.

Also it is likely that there is some information already in your
Xorg.0.log.
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre
_______________________________________________
xorg@xxxxxxxxxxx: X.Org support
Archives: http://lists.freedesktop.org/archives/xorg
Info: http://lists.x.org/mailman/listinfo/xorg
Your subscription address: list-xorg@xxxxxxxxxxx


[X Forum]     [Nouveau Driver]     [Devices]     [XFree86]     [XFree86 Newbie]     [Site Home]     [IETF Annouce]     [Security]     [Fontconfig]     [Bugtraq]     [Photo]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Video for Linux]     [Linux RAID]     [Linux Resources]

Powered by Linux