Google
  Web www.spinics.net

Re: [ANNOUNCE] xf86-video-ark 0.7.4

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Thu, Jan 26, 2012 at 7:04 PM, Robby Workman <robby@xxxxxxxxxxxxx> wrote:
> On Thu, 26 Jan 2012 18:10:30 -0500
> Matt Turner <mattst88@xxxxxxxxx> wrote:
>
>> This release contains a bunch of janitorial fixes, but does contain an
>> actual bug fix from Ondrej Zary (bug 28249).
>
> Why does it depend on a devel release of libpciaccess?
>
> checking for PCIACCESS... no
> configure: error: Package requirements (pciaccess >= 0.12.901) were not met:
> Requested 'pciaccess >= 0.12.901' but version of pciaccess is 0.12.1
>
> -RW

It uses the pci_device_map_legacy function in place of the deprecated
xf86MapDomainMemory function.

I assume that you're a packager, and not an xf86-video-ark user, so if
you want to avoid the development libpciaccess dependency, you can
reverse http://cgit.freedesktop.org/xorg/driver/xf86-video-ark/commit/?id=99ed4177

I think a new libpciaccess release will be along before too much longer.

Matt
_______________________________________________
xorg@xxxxxxxxxxx: X.Org support
Archives: http://lists.freedesktop.org/archives/xorg
Info: http://lists.x.org/mailman/listinfo/xorg
Your subscription address: list-xorg@xxxxxxxxxxx


[X Forum]     [Nouveau Driver]     [Devices]     [XFree86]     [XFree86 Newbie]     [Site Home]     [IETF Annouce]     [Security]     [Fontconfig]     [Bugtraq]     [Photo]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Video for Linux]     [Linux RAID]     [Linux Resources]

Powered by Linux