Google
  Web www.spinics.net

Re: libxcb-1.8 build error (FreeBSD amd64 10.0-CURRENT)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Wed, 18 Jan 2012 01:25:59 -0600
"Conrad J. Sabatier" <conrads@xxxxxxx> wrote:

> On Wed, 18 Jan 2012 08:07:29 +0100
> Arkadiusz Miśkiewicz <arekm@xxxxxxxx> wrote:
> 
> > On Tuesday 17 of January 2012, Conrad J. Sabatier wrote:
> > > Unable to solve this one.  Any pointers, anyone?
> > 
> > Update your xcb-proto package to 1.7. Someone forgot to do the bump
> > in configure check.
> 
> Yep, that did the trick!  Thanks!

Unfortunately, after installing the new xcb-proto and libxcb, X stopped
working.  Obviously, I need to rebuild some other Xorg packages.  The
problem is that the dependency tracking method used by FreeBSD's ports
collection and its tools often causes packages to be listed as
dependent on a given package when they are, in fact, only indirectly
dependent, yielding excessively large lists of dependent packages.  In
the case of libxcb, pkg_info lists 771 dependent packages!

This is clearly absurd.  I've temporarily reverted to the previous
version of libxcb until I can sort out this mess.  <groan>

-- 
Conrad J. Sabatier
conrads@xxxxxxx
_______________________________________________
xorg@xxxxxxxxxxx: X.Org support
Archives: http://lists.freedesktop.org/archives/xorg
Info: http://lists.x.org/mailman/listinfo/xorg
Your subscription address: list-xorg@xxxxxxxxxxx



[X Forum]     [Nouveau Driver]     [Devices]     [XFree86]     [XFree86 Newbie]     [Site Home]     [IETF Annouce]     [Security]     [Fontconfig]     [Bugtraq]     [Photo]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Video for Linux]     [Linux RAID]     [Linux Resources]

Powered by Linux