Google
  Web www.spinics.net

Griffin Powermate evdev setup

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Dear Experts,

I have a Griffin Powermate; it's a USB "knob" that you can use for 
scrolling etc.  This morning the computer that it was attached to 
died.  I'm now having trouble getting to work with the substitute machine.

It looks like I have the kernel stuff working OK:

# od -x /dev/input/by-id/usb-Griffin_Technology__Inc._Griffin_PowerMate-event-misc
0000000 e5f3 49f4 6a00 000c 0002 0007 ffff ffff
0000020 e5f3 49f4 6a1d 000c 0000 0000 0000 0000
0000040 e5f3 49f4 dae9 000e 0002 0007 ffff ffff
0000060 e5f3 49f4 dafa 000e 0000 0000 0000 0000
0000100 e5f3 49f4 3897 000f 0002 0007 ffff ffff
0000120 e5f3 49f4 38aa 000f 0000 0000 0000 0000
0000140 e5f4 49f4 34e8 0000 0002 0007 ffff ffff
0000160 e5f4 49f4 34f6 0000 0000 0000 0000 0000

I've extracted this from the backup of the dead machine's /etc/X11/xorg.conf:

Section "InputDevice"
	Identifier	"Griffin Powermate"
	Driver		"evdev"
	#Option		"Device"		"/dev/input/by-id/usb-Griffin_Technology__Inc._Griffin_PowerMate-event-misc"
	Option		"Name"			"Griffin PowerMate"
	Option		"SendCoreEvents"	"true"
	Option		"DIALRelativeAxisButtons" "4 5"
EndSection

Note the use of Option Name and the commented-out Option Device; I 
recall that it took me a while to get that stuff right.  I believe that 
was working with the Debian package xserver-xorg-input-evdev 1.1.2-1.

On the substitute machine I have xserver-xorg-input-evdev 1:2.0.8-1.  
"man evdev" does not mention "Option Name" and I have the impression 
that it has gone; when I use that config fragment as-is I get an error 
in the log saying that I haven't specified a device [sorry, I can't get 
the exact message now without restarting X].  If I use the Option 
Device line (or Option Path) I instead get this:

(**) Griffin Powermate: always reports core events
(**) Griffin Powermate: Device: "/dev/input/by-id/usb-Griffin_Technology__Inc._Griffin_PowerMate-event-misc"
(WW) Griffin Powermate: Don't know how to use device
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "Griffin Powermate"

So, what does "Don't know how to use device" mean?

Any help would be much appreciated.  If you CC: me in any replies, I'll 
see them sooner.


Thanks,

Phil.





_______________________________________________
xorg mailing list
xorg@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/xorg

[X Forum]     [Devices]     [XFree86]     [XFree86 Newbie]     [Site Home]     [IETF Annouce]     [Security]     [Fontconfig]     [Bugtraq]     [Photo]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Video for Linux]     [Linux RAID]     [Linux Resources]

Powered by Linux