[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Second try: Problems with german localization of xfree86 4.4.0



Hi,

maybe I made a mistake in my first two messages so I try it again.

First my System is a Power Mac G4 with Mac OS X 10.3.2 and all the 
latest patches, fink Package manager version: 0.19.1, Distribution 
version: 0.6.2.cvs and Xfree86 4.4.0 installed via fink, also gnome 
2.4.1-2 via fink with metacity as windowmanager. 

Two days ago fink installed Xfree86 4.4.0 on my system and 
everything seemed to run fine on a first glance but a second one 
showed two big errors.

First error I am not longer able to use the EuroSign and at Symbol 
within OpenOffice.org1.1.1RC1 and abiword and gedit etc, only 
within terminal and gnome-terminal and rxvt this is possibel. I 
first thought that maybe this is a gnome error and used twm and 
englightenment, both not installed via fink, and there the same 
error. I simply can not use the EuroSing and at Symbol along with 
the keycombos for è and é etc. Since the german.keymapping is gone 
in Panther the system keyboard is used and this was just fine in 
RC1, while RC3 didn't build right, see Bug 1182. 

When launching soffice via command line this message ist displayed. 

I18N: Operating system doesn't support locale ""


Second error is somewhat related to the first one. Files and Names 
containing the special chars mentioned above are not shown or show 
wired chars or cause a crash of the xterm when using Xfree86 4.4.0. 
I tried it again with gnome's Metacity, englightenment and twm. The 
first error that occures when a new xterm is launched, equal which 
windowmanager is used is this:

Warning: could not change ownership of tty -- pty is insecure!

Here is the output when X is launched via terminal:

Maveric:~ erichoch$ startx


2004-03-13 12:40:01.395 XDarwin[4065] 
XDarwin 1.3.0

XFree86 Version 4.4.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 29 February 2004
        If the server is older than 6-12 months, or if your 
hardware is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/FAQ)
Operating System: Darwin Apple Computer, Inc.
Could not find keymapping file Deutsch.keymapping.
Reading keymap from the system.
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
Loading GLX bundle glxMesa.bundle (using Mesa)
Display mode: Full screen Quartz -- Direct Display
Screen 0 added: 1280x1024 @ (0,0)
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, 
removing from list!

I thought that  maybe the problem in some way is fink related but 
the original sources show the same behaviour. I downloaded them and 
compiled them for myself. I haven't tried the binaries for darwin 
7.x but I guess they show the same behviour or are they compiled 
with special flags? 

I also tried various ways of setting the LANG variable as you can 
see here in my .profile.

. /sw/bin/init.sh
alias daily='sudo /etc/daily'
alias weekly='sudo /etc/weekly'
alias monthly='sudo /etc/monthly'
alias tunnel='ssh -2 -x -L 2401:localhost:2401 
tunnel@xxxxxxxxxxxxxx'
# alias ls='ls -v  -G'
alias unset_ooo='unset LD_SEG_ADDR_TABLE LD_PREBIND 
LD_PREBIND_ALLOW_OVERLAP'
LANG=de_DE; export LANG
# export LANG=de_DE
# export LC_ALL=de_DE
unset LC_ALL
QTDIR=/Developer/qt
PATH=$QTDIR/bin:$PATH
MANPATH=$QTDIR/doc/man:$MANPATH
DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH

export QTDIR PATH MANPATH DYLD_LIBRARY_PATH

When exclude the LANG=de_DE, export LANG line wiht an # the second 
error dissapears. I can but still I cannot use @, EuroSign etc and 
all is english again and that never caused any problems. 

Need I recompile gnome, metacity, englightenment or is the error 
another one.

Since I use Mac OS X I have no Xfre86.log. So please tell me what 
further informations you need and where I can find them. I can send 
you my .xinitrc if necessary or the general log file of Mac OS X if 
it helps. 

I understand that my errors may not occure with english Xfree 4.4.0 
on Macintosh but I am german nativ and I need an EuroSign and at 
Symbol here on my mac and maybe french and other european languages 
are effected too. 

Regards, 
Eric Hoch

-- 
## Ansprechpartner Anwenderunterstützung, users-Mailingliste
## War unsere Hilfe erfolgreich? Bitte teilen Sie es uns mit. Danke.
## de.OpenOffice.org - Office für MacOS X, Linux, Solaris & Windows 
## Netikette? http://www.eschkitai.de/openoffice/netikette.html

_______________________________________________
XFree86 mailing list
XFree86@xxxxxxxxxxx
http://XFree86.Org/mailman/listinfo/xfree86

[X Forum]     [Xorg]     [XFree86]     [XFree86 Newbie]     [IETF Announce]     [Security]     [Fontconfig]     [Bugtraq]     [Photo]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Video for Linux]     [Linux RAID]     [Linux Kernel]

Powered by Linux