[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Hit bound texture in upload



I'm getting a lot of 
 Hit bound texture in upload
in quake3. 

Whenever I get a message like this I also see corrupted textures on the
screen. From what I read in the source it appears this happens when mmAllocMem
returns 0 which sounds like it means out of memory. But I think I have plenty
of memory available. I know I have plenty of swap available.

Is this a known problem? On google I see a few other mentions of people
reporting this but nobody working on fixing it.

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04) (prog-if 00 [VGA])
	Subsystem: Matrox Graphics, Inc. Millennium G400 16Mb SDRAM

>From /u6/src/xfree86/xc/lib/GL/mesa/src/drv/mga/mgatexmem.c:

int mgaUploadTexImages( mgaContextPtr mmesa, mgaTextureObjectPtr t )
...
	 t->MemBlock = mmAllocMem( mmesa->texHeap[heap],
				   t->totalSize,
				   6, 0 );
	 if (t->MemBlock)
	    break;

	 if (mmesa->TexObjList[heap].prev->bound) {
	    fprintf(stderr, "Hit bound texture in upload\n");
	    return -1;
	 }





-- 
greg

_______________________________________________
Xpert mailing list
Xpert@xxxxxxxxxxx
http://XFree86.Org/mailman/listinfo/xpert




[XFree86]     [XFree86 Newbie]     [X.Org]     [Site Home]     [IETF Annouce]     [Security]     [Bugtraq]     [Share Pictures]     [Rubini]
[Photo]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [XFree86 Forum]     [Linux Resources]

Powered by Linux