Google
  Web www.spinics.net

Re: [SOLVED]Re: failure of persistence of control key

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Wed, 17 Nov 2010, Mike Miller wrote:

It looks like I have solved this problem. I don't think it has anything to do with VNC. I have two Ubuntu boxes -- one in my office running Xvnc server and one at home. When I was connecting to office Xvnc from home, it was working fine. When I connected to Xvnc in the office from that same office Ubuntu machine, I was getting the issue described below. I thought about what was different between home and office. At home I had enabled this option in Gnome > System > Preferences > Mouse:

show position of pointer when the Control key is pressed

It was not enabled on the office machine. I enabled it in the office and then the problem was solved. Note that Gnome is running on the desktop of the machine that is running Xvnc, but I'm not using Gnome in VNC, I'm using IceWM.

It's funny, isn't it? I would have thought that enabling that feature would have caused problems, not the other way around, but enabling the feature fixed the problem.


Unfortunately, I was mistaken about that fix. I think the problem has something to do with full-screen mode. If I am not in full screen mode, my ctrl keys don't work -- not for keystrokes and not for mouse clicks -- but they do work in full-screen mode. When I am connecting to localhost, it seems that after some time my control keys will stop working correctly, losing their persistence, but when I leave full-screen mode and return to it, they will work correctly again. Leaving full-screen mode to change Gnome settings provided a temporary fix, but not because I had changed the settings. So this issue remains "NOT SOLVED." ;-(

Mike

_______________________________________________
VNC-List mailing list
VNC-List@xxxxxxxxxxx
To remove yourself from the list visit:
http://www.realvnc.com/mailman/listinfo/vnc-list


[Books]     [Home]     [Photo]     [Yosemite]     [Hot Springs]     [VNC Home]     [PDAs]     [Open Source Now]     [Epson Inkjet]

Add to Google Reader or Homepage Powered by Linux