Google
  Web www.spinics.net

Re: [SOLVED]Re: failure of persistence of control key

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Wed, 17 Nov 2010, Mike Miller wrote:

It looks like I have solved this problem. I don't think it has anything to do with VNC.

I shouldn't have said that because I don't know the cause. It could be the interaction of VNC viewer with the Gnome system, but it also could be caused by IceWM's interactions with Gnome and have nothing to do with VNC, or it could be an interaction of all three together messing things up. All I know is that the change described below fixed it immediately.

Mike


I have two Ubuntu boxes -- one in my office running Xvnc server and one at home. When I was connecting to office Xvnc from home, it was working fine. When I connected to Xvnc in the office from that same office Ubuntu machine, I was getting the issue described below. I thought about what was different between home and office. At home I had enabled this option in Gnome > System > Preferences > Mouse:

show position of pointer when the Control key is pressed

It was not enabled on the office machine. I enabled it in the office and then the problem was solved. Note that Gnome is running on the desktop of the machine that is running Xvnc, but I'm not using Gnome in VNC, I'm using IceWM.

It's funny, isn't it? I would have thought that enabling that feature would have caused problems, not the other way around, but enabling the feature fixed the problem.

Mike


On Mon, 8 Nov 2010, Mike Miller wrote:

I'm using Xvnc Free Edition 4.1.1 on my Ubuntu 9.10 system and connecting using either VNC Viewer Free Edition 4.1.1 for X - built Apr 16 2008 13:23:14, or the VNC Viewer Enterprise Edition E4.4.3 (r16583) for X Built on Oct 14 2008 00:18:24 -- both give me the same problem. I'm using IceWM.

I'm running the viewer on the same machine as the server -- I like the portability -- but I have problem where I hold down the control key and press some letter, like 'f', and use that to move my cursor in some program like emacs, and the control key just stops working at some point and I end up with ffffffffffffff on my screen. This doesn't happen on the same computer with the same keyboard if I leave the vncviewer and just go to an xterm in Gnome. I don't know if this is a VNC problem of an IceWM problem.

Any ideas?

Mike

_______________________________________________
VNC-List mailing list
VNC-List@xxxxxxxxxxx
To remove yourself from the list visit:
http://www.realvnc.com/mailman/listinfo/vnc-list


[Books]     [Home]     [Photo]     [Yosemite]     [Hot Springs]     [VNC Home]     [PDAs]     [Open Source Now]     [Epson Inkjet]

Add to Google Reader or Homepage Powered by Linux