Google
  Web www.spinics.net

Mixing tagged and untagged vlans using via-velocity driver

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I am trying to setup two vlans (one tagged and one untagged) using the
native via-velocity driver in kernel 2.6.21.1 on a single nic.

I can set it up tagged or untagged without any problems, but not both at the
same time. Is this even possible with this driver?

To enable vlan5 tagging on the nic I have tried the following:

alias eth1 via_velocity
options eth1 enable_tagging=1 VID_setting=5

At this point I can communicate with vlan5. When I try to bring up a virtual
interface using vconfig it seems to inherit the vlan5 tagging, thus making
it impossible to communicate with an untagged vlan.

I have also tried the other way arround. If I skip "enable_tagging=1
VID_setting=5", I can communicate with a non tagged vlan. If I bring up a
new virtual interface (tagged vlan5) using vconfig it does not work.

I'm stuck. If anyone could shed some light on this it would be greatly
appreciated.

 

Nicklas

_______________________________________________
Vlan mailing list
Vlan@xxxxxxxxxxxxxxx
http://www.candelatech.com/mailman/listinfo/vlan

[Netdev]     [Ethernet Bridging]     [Linux Wireless]     [Kernel Newbies]     [Security]     [Linux for Hams]     [Netfilter]     [Bugtraq]     [Photo]     [Yosemite]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Linux Admin]     [Samba]     [Video 4 Linux]     [Linux Resources]

Powered by Linux