Re: [PATCH 5/5] pxa-camera: framework to handle camera-native and synthesized formats

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

On Tue, 11 Nov 2008, Robert Jarzmik wrote:

> Guennadi Liakhovetski <g.liakhovetski@xxxxxx> writes:
> > Don't you think we can have a default case? If the format requested by the 
> > user is provided by the camera and we "can trandfer it 1-to-1" (bus-width 
> > == depth or some such) then just switch on the pass-through mode?
> Yes, we should, you're perfectly right.

Which means we cannot have your suggested static list of host-camera 
formats, right?

> > Wow, I'm scared...:-) Ok, let's try it your way, I don't want to play the 
> > "maintainer" card, and you seem to be strongly in favour of a central 
> > solution, whereas I just slightly incline towards local... So, either give 
> > me a few days, or feel free to code off - whichever you prefer.
> Well, since I bring the burden, I'll bring in the solution too, that's fair.
> What I can do is make the translation in pxa_camera, but generic enough so that
> it's transplantation to soc_camera is only a matter of copy/paste (with a bit of
> renaming).
> That way, we'll have :
>  - the local model holding : no centralization in soc_camera
>  - if you see a wave of incoming host cameras copy pasting that bit of code,
>  transplant that to soc_camera.
>  - tradeoff between your model and my model.
> Do you like that approach ? If you prefer the soc_camera one (translation code
> in soc_camera), I'll put it in there, just tell me.

Emn, no, what you're describing is what I have done in my patch and what 
you didn't like - a solution local to pxa-camera but generic enough to be 
easily converted to a central one... My understanding was, that you wanted 
a central solution straight away, I agreed, and now you're looking for 
compromises?...:-) hm, no, please don't. You win, I lose, please code it 
for soc_camera.c.

> > If you do this, I think, best do something like
> >
> > int soc_camera_host_register(struct soc_camera_host *ici)
> > {
> > ...
> > 	if (!ici->ops->enum_fmt)
> > 		ici->ops->enum_fmt = soc_camera_enum_fmt;
> > ...
> >
> > etc. for any other methods you want to provide defaults for. Instead of 
> > exporting more functions and letting hosts do
> >
> > int x_do_something(...)
> > {
> > 	return soc_camera_do_something(...);
> > }
> Yep. Sounds less poluting to kernel namespace.
> OK, now I'm on the coding path, let's see what futur brings :)

Looking forward:-)

Guennadi Liakhovetski, Ph.D.
Freelance Open-Source Software Developer

video4linux-list mailing list
Unsubscribe mailto:video4linux-list-request@xxxxxxxxxx?subject=unsubscribe

[Linux Media]     [Older V4L]     [Linux DVB]     [Video Disk Recorder]     [Linux Kernel]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Util Linux NG]     [Xfree86]     [Free Photo Albums]     [Fedora Users]     [Fedora Women]     [ALSA Users]     [ALSA Devel]     [SSH]     [DVB Maintainers]     [Linux USB]     [Yosemite Information]

Add to Google Powered by Linux