Google
  Web www.spinics.net

Re: softdevice with menu&audio but no video

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


>>>>>> The problem
>>>>>> is that although I can hear the channel playing and I can see and use
>>>>>> the vdr menus using softdevice I can't view the actual program wether or
>>>>>> not it's live or recorded.
>>>>>>
>>>>>>             
>>>>> Ae you using Xv output? It's prob the wrong colour key used for the
>>>>> overlay. Search the softdevice devel for a fix.
>>>>>
>>>>> --Torgeir Veimo
>>>>> torgeir@xxxxxxxx
>> I'm using nvidiafb with a GF 6600.
>>     
>
> 6600 ... I think that was the series, where they (nvidia) dropped
> the overlay unit. When I remind this correct, from this series on only
> the blitter can be used. So it _could_ be, that when selecting YUY2 as
> output pixel format _and_ setting "Use StretchBlit" to yes, video is shown.
> But this depends on DirectFB's driver capabilities too.
>
>   
Bingo! Video at last. It now introductes an audio stutter and some weird 
menu colours but as my target system won't have that card (it's a modded 
xbox which I'll get a usb1 tv-stick for) it doesn't bother me.
>> However normal framebuffer is also
>> showing menus but no video. Also shouldn't colourspace errors mean I get
>> no menus either?
>>     
>
> Menus are drawn directly to framebuffer in RGB.
>
> Stefan Lucke

_______________________________________________
vdr mailing list
vdr@xxxxxxxxxxx
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

[Linux Media]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Util Linux NG]     [Xfree86]     [Devices]     [Big List of Linux Books]     [Fedora Users]     [Webcams]     [Fedora Women]     [ALSA Devel]     [Linux USB]

Powered by Linux