Google
  Web www.spinics.net

Re: mount -f regression in v2.21's new-mount

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Thu, Mar 08, 2012 at 08:25:00PM +0000, Matt Burgess wrote:
> I've attached LIBMOUNT_DEBUG output from the 'mount -a' call that our
> bootscript does.  Note how mount correctly detects that /proc, /sys

 No, it calls mount(2) syscall for /proc. The problem is that the
 detection code expects /proc/self/mountinfo (used on systems with
 mtab -> /proc/mounts symlink), but your system uses regular mtab.

 I'll fix it. Thanks.

    Karel

> 239: libmount:      CXT: [0x184f060]: mount(2) [source=proc, target=/proc, type=proc,  mountflags=0xc0ed000e, mountdata=<none>]
> 239: libmount:      CXT: [0x184f060]: mount(2) failed [errno=16 Device or resource busy]
> mount: proc is already mounted or /proc busy
>        proc is already mounted on /proc


-- 
 Karel Zak  <kzak@xxxxxxxxxx>
 http://karelzak.blogspot.com
--
To unsubscribe from this list: send the line "unsubscribe util-linux" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Site Home]     [Netdev]     [Ethernet Bridging]     [Linux Wireless]     [Kernel Newbies]     [Memory]     [Security]     [Linux for Hams]     [Netfilter]     [Bugtraq]     [Rubini]     [Photo]     [Yosemite]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Linux Admin]     [Samba]     [Video 4 Linux]     [Linux Resources]

Powered by Linux