Nokia 6110 Navigator on USB: " bad CDC descriptors"

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Hi,

I just tried to plug a Nokia 6110 Navigator  (USB) into a Linux box
with a 2.6.22 kernel. No ethernet device appeared, but the kernel
issued the error message

   usb 2-5: bad CDC descriptors

which seems to come from the cdc_ether driver.

(when using a Sony Ericsson K610i the ethernet device usb0 is created, I
had expected the same to happen with the Nokia).


Has anyone seen/analyzed/solved this problem before? Is it a problem of
the Nokia
or of the kernel?

Any hints for debugging (except for defining DEBUG and recompiling the
kernel)?

regards
Hadmut

 



-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >> http://get.splunk.com/
_______________________________________________
Linux-usb-users@xxxxxxxxxxxxxxxxxxxxx
To unsubscribe, use the last form field at:
https://lists.sourceforge.net/lists/listinfo/linux-usb-users

[Index of Archives]     [Linux USB]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]    [Yosemite Photos]    [Linux Kernel]     [Linux SCSI]     [XFree86]