[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Re: Need help configuring tux and apache to work together for localhost and virtual hosting



Based on questions and some trial and error, I think I have the problem solved, but don't ask me how. :)

My system crashed completely - just locked up everywhere with some repeated disk access like an infinite loop. When it came back up after I pressed the reset button, localhost and all the IP addresses worked fine.

I had been experimenting with changes based on the questions, so I don't remember exactly what may have been changed.

I have confirmed that the order of the addresses in the host file does not seem to matter. It also doesn't seem to matter whether the httpd.conf file has "ServerName Linux.net" or "ServerName 127.0.0.1", as I have tested both of these after the restart (restarting tux and httpd for each test).

Gremlins!


On Tue, 16 Mar 2004 17:47:49 -0500, Ralph E. Kenyon, Jr. <diogenes@vgernet.net> wrote:

On Tue, 16 Mar 2004 13:45:33 -0500, Chris Davies <mcd@daviesinc.com> wrote:

On Tue, 2004-03-16 at 13:21, Ralph E. Kenyon, Jr. wrote:
But now I have a different problem. I can no longer see the default host on the linux machine. (/var/www/html is no longer accessible from either
my linux machine or from my windows machine via the lan.)
what virtual host is set to answer for /var/www/html


linux.net, but it does not answer any requests

However, I can no longer see the linux local host site from either the
linux machine or the W2K machine.
Entering http://192.168.0.2/ on the W2K machine simply produces a blank
screen after some delay.
do you have ServerName 192.168.0.2 defined somewhere?

I don't think so. I didn't have ServerName in httpd.conf for this address.
Tux is supposed to listen to everything on port 80.

I tried adding ServerName 192.168.0.2 to httpd.conf, but it did not make
any difference.

SeverName linux.net is defined in httpd.conf
I tried changing it to 192.168.0.1 as well as to 127.0.0.1, but neither
worked.

Entering http://127.0.0.1/ on the linux machine does the same.
do you have ServerName 127.0.0.1 defined somewhere?

I tried changing / adding ServerName 127.0.0.1 to httpd.conf.  It didn't
make any difference.


The tux log does not show a GET request corresponding to either of these
events.  Neither does the apache log.
It looks like the request is not being seen by Tux.

telnet 192.168.0.2 80
GET / HTTP/1.0
Host: 127.0.0.1

(then hit enter twice)


The "80" part doesn't work.
I can start telnet and then open 192.168.0.2.
GET / HTTP/1.0 returns a web page with a directory of the linux machine
"/" before the Host: line can be typed.






I can read file://localhost and get the root directory of the linux system
(from the linux system), but,
http://localhost/ just comes back blank.
is it defined in apache as a valid servername?

i.e. ServerName localhost

hosts.conf has

127.0.0.1       localhost.localdomain localhost linux.net xenodochy.org
ballroomdances.org





--
Using M2, Opera's revolutionary e-mail client: http://www.opera.com/m2/



[Older Fedora Users Mail]     [Home]     [Fedora Legacy]     [Fedora Desktop]     [iPod Nano]     [ATA RAID]     [Fedora Bible]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Packaging]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

Powered by Linux

Google
  Web www.spinics.net