[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Tux unstablity and bugs



Hey list,

I'm running Tux now for a couple of days and noticed some strange things.

The situation:
All web files (around 65k and still growing) are on an NetApp NFS server.
That server is mounted under /web
Tux is running, using a docroot: /web/tux
Vhosts in that dir are symbolic links, ln -s ../tweakers/tweakers.net
tweakers.net
I have 2 load balanced pools.

This is running, and it is fast. But only when the server is in one pool.
When I insert the server in both pools, the server crashes in less then 10
secs with a kernel oops and an unreachable NFS mount, and both Apache and
Tux hanging.

The errors in the syslog (with NFS debugging on):
http://www.tweakers.net/~kees/nfs.txt

next thing I did was install Tux on a server with the files on the local
disk, this is a dual PIII server, so I started tux with 2 threads. It was a
mistake, because Tux hung at once. When i tried to stop it using tux -s it
simply ate up the idle time of one processor and I had to reboot the server.
After that i tried to run it with 1 thread, which worked.

So I started playing with compression. I made a gzipped file of every image
(find rocks ;)) and turned on compression. After I while I got complaints
from users who couldn't saw images. So I did some ab's on the images and
couldn't see the problem (more than 10k req/s actually). Next I used IE to
reload the images and on a page with +60 images it took more than 4 minutes
to get them all. I don't know what exactly caused it, but when i turned off
the compression, IE was able to reload the page including the images in less
than a second.

Also I noticed that tux wouldn't follow all symlinks, even if all the
permissions were right, it simply passed it on to apache. I think i have to
use mount -o bind for those, but I don?t like it ;).

So after a long story, my questions:
What is causing rpciod/nfs/tux to crash?
Why is it impossible for me to use 2 threads on a SMP box?
Is turning on compression such a performance hit that tux would drop from
10k req/s to 10 req/s?
Which symlinks does tux follow? when will tux decide to stop following
symlinks? (is there a max-depth?)

Finally some specs:
Kernel: 2.4.18
OSses Slackware 8.1 and 8.0-beta
Tux: 2.2.7 and  tux2-full-2.4.18-final-A3 patch
Celeron 1200 w/ 512MB ram and a dual PIII-1GHz w/ 1G ram

I hope someone can enlighten me :)

Kees Hoekzema






[Older Fedora Users Mail]     [Home]     [Fedora Legacy]     [Fedora Desktop]     [iPod Nano]     [ATA RAID]     [Fedora Bible]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Packaging]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

Powered by Linux

Google
  Web www.spinics.net