[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Strange tux problem



Hi!

We've been running Tux on our production servers for a while
now, and so far it's been great. We're running an Apache backend,
which serves stuff like PHP and SHTML. Tux version is 2.2.0-1.

Today, a pretty ordinary request failed for the first time:

GET /redir.php?program=010-029 HTTP/1.1
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, */*
Accept-Language: da
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Host: 010.xxxx.com
Connection: Keep-Alive

The connection was closed before we got any response.
Checking the Apache log, it turns out the request never reached the
backend. PHP is listed under TUX/redirect in tux.mime.types - infact
it worked like a charm yesterday :-) The Apache backend is running
on port 8080, and a direct request is served right.
I tried Tux again, this time with an accidental linefeed before the
GET line, and this time it served the request. Puzzeling, eh? :-)

I'm running RH72 with plain vanilla kernel-smp-2.4.9-31.
Tux version is 2.2.0-1.


Cheers,
HC

-- 
Hans Christian Saustrup
Chief of Research/Development
Digital Team ApS - a division of Media-I
Frederiksgade 76A / DK-8000 Aarhus C / Denmark

Value your privacy - use PGP/GPGuard.





[Older Fedora Users Mail]     [Home]     [Fedora Legacy]     [Fedora Desktop]     [iPod Nano]     [ATA RAID]     [Fedora Bible]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Packaging]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

Powered by Linux

Google
  Web www.spinics.net