Search squid archive

Re: Re: FTP through squid

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]





I don't know if this is related...

I had some problems like this one, using filezilla, but I don't remember which was the log message.

I had, from old configuration files, the directive :

   ftp_passive off

and this was the reason. I just commented it out and the proxy works now as a charm.

Hugo Deprez wrote:
Hello,

I just installed squid3 from wheezy repository :

ii  squid3                              3.1.19-1+b1
Full featured Web Proxy cache (HTTP proxy)
ii  squid3-common                       3.1.19-1
Full featured Web Proxy cache (HTTP proxy) - common files

I try with FF12 still the same issue :

******* - - [06/May/2012:18:47:17 +0200] "GET ftp://ftp.free.fr/
HTTP/1.0" 504 4118 "-" "Mozilla/5.0 (Windows NT 5.1; rv:12.0)
Gecko/20100101 Firefox/12.0" TCP_MISS:DIRECT

I tried with filezilla, I get the following error :


***** - - [06/May/2012:18:44:56 +0200] "CONNECT ftp.free.fr:21
HTTP/1.0" 200 266 "-" "FileZilla" TCP_MISS:DIRECT
***** - - [06/May/2012:18:44:57 +0200] "CONNECT 212.27.60.27:6846
HTTP/1.0" 403 3561 "-" "FileZilla" TCP_DENIED:NONE

seems that the client is using passive mode, as it try to connect to
the FTP server to the port 6846.
How to deal with that ?
What is the difference between firefox and filezilla from FTP's
protocol point of view ?

Thanks !



--

 Envoyé de ma machine à écrire.



[Linux Audio Users]     [Photo]     [Yosemite News]     [Samba]     [Video Projectors]     [Video Devices]     [Big List of Linux Books]     [LCD TVs]     [Webcams]     [Linux USB]

  Powered by Linux