silo trouble with ext3

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Short summary: silo can not find any files from my ext3. Was this 
the problem recently discussed here about silo?

Debian unstable's silo 1.4.14+git20120127-1 and 110G ext3 filesystem. 
The same machine worked fine for years, running all the kernels and 
Debian unstable. Last successful reboot was less than a week ago, and 
Debian was updated after that (probably updating silo package).
Today I compiled 3.3-rc4+git and rebooted to try it, and silo can not 
find anything. silo itself loads but can not open neither /etc/silo.conf 
nor any kernel image by direct name:

Rebooting with command: boot                                          
Boot device: disk  File and args: 
SILO Version 1.4.14

Cannot find /etc/silo.conf (error: 4294967295)

Couldn't load /etc/silo.conf
No config file loaded, you can boot just from this command line
Type [prompath;]part/path_to_image [parameters] on the prompt
E.g. /iommu/sbus/espdma/esp/sd@3,0;4/vmlinux root=/dev/sda4
or 2/vmlinux.live (to load vmlinux.live from 2nd partition of boot disk)
boot: 1/boot/test
Allocated 64 Megs of memory at 0x40000000 for kernel

Cannot find /boot/test (error: 4294967295)

Image not found.... try again
boot:


Tried fsck.ext3 -f, did not help. Re-installed silo from netboot 
chroot, did not help either.

This is Ultra 5 with OBP 3.31 (latest available), so should not have any 
1G or 2G limits on boot partition?

Ideas?

-- 
Meelis Roos (mroos@xxxxxxxx)
--
To unsubscribe from this list: send the line "unsubscribe sparclinux" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux MIPS Home]     [Kernel Development]     [DCCP]     [Linux ARM Development]     [Linux]     [Photo]     [Yosemite News]     [MIPS Architecture]     [Linux ARM Kernel]     [Linux SCSI]     [Linux x86_64]     [Linux Hams]

  Powered by Linux