Re: using a variable to increment another variable

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


hello Kevin,

I got to fix the error. When I wrote:


(if (= nFrameAtual 6)
(set! nOpacidadeCamada2 100)
(set! nIncrementoCamada2 0)
)

The second line was ALWAYS executed. I changed to:

(if (= nFrameAtual 6)
(set! nIncrementoCamada2 0)
)
(if (= nFrameAtual 6)
(set! nOpacidadeCamada2 100)
)

And it is working. So, I rewrote it to:

(if (= nFrameAtual 6)
(
(set! nOpacidadeCamada2 100)
(set! nIncrementoCamada2 0)
)
)

But it gives me an error. So, I am trying to find more info about the
if syntax in Scheme. The GIMP version I am using is 2.2.13.

Thanks for your help,
andrei



--- In script-fu@xxxxxxxxxxxxxxx, Kevin Cozens <kevin@...> wrote:
>
> andreithomazgmail wrote:
> > excuse me for not being clear enough. The variable nLayerStep2 doesn't
> > change too.
> [snip]
> > If needed, I can send the .scm and .xcf file I am using.
> 
> Please put your script online somewhere so it can be
viewed/downloaded. Also 
> state which version of GIMP you are using. What you are reporting
makes no 
> sense. It is most likely some bug in your script but I won't know
for sure 
> until I can see the it.
> 
> -- 
> Cheers!
> 
> Kevin.
> 
> http://www.ve3syb.ca/           |"What are we going to do today, Borg?"
> Owner of Elecraft K2 #2172      |"Same thing we always do, Pinkutus:
>                                  |  Try to assimilate the world!"
> #include <disclaimer/favourite> |              -Pinkutus & the Borg
>



Photo 4 Less

[Gimp Developers]     [Gimp Users]     [Photos]     [Yosemite News]     [Yosemite Photos]    [Epson Inkjet]     [Scanner]     [Gimp's Home]     [Steve's Art]

Add to Google Powered by Linux