Re: After upgrade samba4 to beta version i've got "network path not found"

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



On Thu, 2012-08-16 at 16:09 +0300, h2x0r@xxxxxxxxx wrote:
> Hello,
> 
>  
> 
> I'm using samba4 as domain controller with new forest domain (not existing
> domain) and everything is fine but.. one day when I usually do upgrades of
> my system I saw samba4 will be upgraded to beta version. Everything went
> fine after upgrade, but I cannot join new computers to the AD anymore. I got
> "network path not found" when I try to join Windows XP. With Linux I got
> "connection refused".
> 
>  
> 
> I also try to make new installation of Debian stable, then upgrade to wheezy
> and make Samba4 provision as active directory. Everything the same. I cannot
> join to the Active Directory.
> 
>  
> 
> Only one difference, in first case I have Windows XP successfully joined,
> and I can manage the Active Directory.
> 
> Can somebody help me with debugging that?

If this is a debian system, you may need to set:

server services = +smb -s3fs
dcerpc endpoint servers = +winreg +srvsvc

see:
https://wiki.samba.org/index.php/Samba4/s3fs#Using_it

Debian ships with only part of Samba4, not including the smbd file
server that is now the default.  The above restores the use of the
included ntvfs file server.

If this fixed it for you, you will need to file a bug with debian for
them to deal with this properly on upgrade. 

Andrew Bartlett

-- 
Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba


[Linux]     [Info Cyrus]     [LARTC]     [Bugtraq]     [Netfilter]     [Internet Dating Forums]     [RAID]     [Yosemite News]     [Photography]

Add to Google Powered by Linux