[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Re: [Redhat-s390-list] support for older machines?




Bernhard Rosenkraenzer wrote:

> On Mon, 26 Feb 2001, Bellussi Giorgio wrote:
>
> > Question 1.
> > Suse and Turbolinux distributions are supported only on G5 or G6 machines
> > (unlike intel flavours, which should work also with ancient 386!).
> > Does Red Hat for s390 will have the same limitations?
>
> At the moment, yes. We don't have older machines to test on.
>
> > lcs.o (the network driver for "lan channel stations" like 3172) is still
> > distributed as OCO (Object Code Only) also under SRPMS directory. Is it
> > permitted by GPL license?
>
> Unfortunately we don't have the source. The package in SRPMS is just the
> binary along with instructions on where to install it and similar stuff.
> Our parts (the spec file - basically a script that copies things where
> they belong) are GPLed.
>
> > (the true question is: there will be some way to be sure the instructions of
> > lcs.o are supported by pre G4 cpu?)
>
> Not unless you convince IBM to release the source.
>
> > BTW: I found a 2.2.15 kernel hacked for pre G3 machines.
>
> Where? If the patch doesn't break anything else, I'd like to include it.

The hacked kernel 2.2.15 and patches can be found at
http://penguinvm.princeton.edu/programs/vintage/

Sorry, I haven't yet the time (and perhaps the skill) to test the patch on a newer
version of kernel...

>
>
> > I tried to IPL it and
> > it worked fine (unlike Marist and SUSE, which hang at dasd initialization) until
> > the step of network setup.
>
> What needs to be done for network setup on a G3?

Nothing particular has to be done to setup network on a G3, just reply to some answer
as for other Gx.
I think that the true problem is: I haven't enough skill about 3172 and I haven't
found enough documentation on how to configure 3172 to linux390.
People at marist wrote: "No problem 3172's support the lcs channel protocol just like
osa devices"... (and no more...)
Unfortunately the plain marist kernel (and the SUSE too), that I suppose ready for
lcs, hangs after the message
"loop: registered device at major 7" and before any "dasd: initializing".
Instead, trying vintage 2.2.15 (the one I said before) + the marist "initrd", the ipl
ran fine until the step "Finding module dependencies", which gives
"/lib/modules/2.2.15/net/lcs.o: unresolved symbol(s)" (BTW ... the symbol is
"tqueue_lock").
Now I outlined my situation completely, and I think it is clear that I cannot test lcs
anyway.
Any help will be appreciated.

Giorgio

begin:vcard 
n:Bellussi;Giorgio
tel;fax:++39-049-8288406
tel;work:++39-049-8288506
x-mozilla-html:TRUE
org:Produzione
version:2.1
email;internet:giorgio.bellussi@infocamere.it
adr;quoted-printable:;;InfoCamere S.C.p.A.=0D=0AC.so Stati Uniti 14;Padova;;35127;Italia
x-mozilla-cpt:;21536
fn:Giorgio Bellussi
end:vcard

[Home]     [LKML]     [Red Hat Install]     [Red Hat Watch]     [Red Hat Development]     [Linux s390]     [Gimp]     [Yosemite News]

Powered by Linux