[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Re: Kompozer 0.83b Install error on Centos 5.5



On Thu, 3 Feb 2011, Marc Deop wrote:

To: General discussion about the RPM package manager <rpm-list@xxxxxxxxxxxxx> From: Marc Deop <damnshock@xxxxxxxxx> Subject: Re: Kompozer 0.83b Install error on Centos 5.5

On Thursday 03 February 2011 10:52:44 Panu Matilainen wrote:
+ desktop-file-install --dir=/var/tmp/kompozer-0.8-0.4.b3.el5-root-rpmbuilde
r/usr/share/applications/ /var/tmp/kompozer-0.8-0.4.b3.el5-root-rpmbuilder/u
sr/share/applications/kompozer.desktop
Must specify the vendor namespace for these files with --vendor

desktop-file-install is saying it requires a --vendor argument for the
.desktop file. Maybe some versions of the desktop-file tools require it
and others dont - I dunno.

Yes. From the --help text:

[root@karsites ~]# desktop-file-install --help
Usage: desktop-file-install [OPTION...]
  --vendor=STRING
  Specify the vendor prefix to be applied to the desktop file.
  If the file already has this prefix, nothing happens.

So I edited the kompozer.spec file and added that argument to the call to with:

## installing kompozer.desktop
# desktop-file-install --vendor=karsites.net --dir=%{buildroot}%{_datadir}/a
pplications/%{buildroot}%{_datadir}/applications/%{name}.desktop

I still got some errors, so I commented that out!

The other thing was I continued the build from the %install section with:

[rpmbuilder@karsites SPECS]$ rpmbuild -bi --short-circuit kompozer.spec

That's dealt with the desktop file error.

I now have the following errors:

Processing files: kompozer-debuginfo-0.8-0.4.b3.el5
Provides: libaccessibility.so.debug libappcomps.so.debug libcaps.so.debug libchrome.so.debug libcommandlines.so.debug libcomposer.so.debug libdocshell.so.debug libeditor.so.debug libembedcomponents.so.debug libfileview.so.debug libgfx_gtk.so.debug libgfxps.so.debug libgfxpsshar.so.debug libgkgfx.so.debug libgklayout.so.debug libgkplugin.so.debug libgtkembedmoz.so.debug libgtkxtbin.so.debug libhtmlpars.so.debug libi18n.so.debug libimgicon.so.debug libimglib2.so.debug libjar50.so.debug libjsd.so.debug libjsj.so.debug libmork.so.debug libmozfind.so.debug libmozgnome.so.debug libmozjs.so.debug libmyspell.so.debug libnecko.so.debug libnecko2.so.debug libnkgnomevfs.so.debug libnsappshell.so.debug libnullplugin.so.debug liboji.so.debug libpipboot.so.debug libpipnss.so.debug libpippki.so.debug libpref.so.debug librdf.so.debug libremoteservice.so.debug libspellchecker.so.debug libstoragecomps.so.debug libtoolkitcomps.so.debug libtxmgr.so.debug libuconv.so.debug libucvmath.so.debug libunixprintplugin.so.debug libwebbrwsr.so.debug libwebdav.so.debug libwidget_gtk2.so.debug libxpcom.so.debug libxpcom_compat.so.debug libxpcom_compat_c.so.debug libxpcom_core.so.debug libxpconnect.so.debug libxpinstall.so.debug libxpistub.so.debug

Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/kompozer-0.8-0.4.b3.el5-root-rpmbuilder

this package was built for Fedora 13:

kompozer-0.8-0.4.b3.fc13.src [42.5 MiB]
Changelog by Ismael Olea (2010-02-23):
 - update to 0.8b3

Is my version of RPM to old to build this package?

TIA

Keith Roberts

-----------------------------------------------------------------
Websites:
http://www.karsites.net
http://www.php-debuggers.net
http://www.raised-from-the-dead.org.uk

All email addresses are challenge-response protected with
TMDA [http://tmda.net]
-----------------------------------------------------------------
_______________________________________________
Rpm-list mailing list
Rpm-list@xxxxxxxxxxxxx
http://lists.rpm.org/mailman/listinfo/rpm-list


[Linux Kernel]     [Red Hat Install]     [PAM]     [Red Hat Watch List]     [Red Hat Development]     [Red Hat]     [Gimp]     [Yosemite News]     [IETF Discussion]