[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Sound] Sound on via vt8235 in RH 8.0



On Wed, Dec 11, 2002 at 11:48:35AM +0530, Jatin Sharma wrote:
> Hi,
> 
> 
> > Good Luck!!! Do not waste time to work on VIA chipset. It's very sick
> > for Linux even with MS Window. I had to return the MB with VIA chipset.
> > Finally Intel MB or some with INtel chipset are working fine. I had to
> > back-and-forth 6 times to FRY to get the right one. Finally I got 
> > 645E MAX with SIS 645DX chipset and it working fine. even with RealPlayer
> > for Linux.
> > Now I am happy with my Linux 8
>  
> Is this applicable for sound only on a VIA chipset. I am planning to buy a
> VIA MB, and plan to use in linux. However I don't have a need for sound. 
> Does anyone has any idea how does a VIA MB perform in linux or is it even 
> compatible ?
Hi

OSS (which is the sound code used by Linux 2.4 and older) doesn't support
later VIA chipsets currently, but ALSA (which will eventually replace
OSS, 2.5 has both) supports them very well. Easiest way to get ALSA running 
is to get the RPMS from http://www.freshrpms.net, then configure it like this:

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-via82xx
# module options should go here
# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-via82xx
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Works perfectly on my Asus A7V8X with a VIA KT400 and only takes a few
minutes to get running from the rpms. I even have AC3 passthrough working
(required a custom alsalib config file, but it was quite trivial to do)

-- 
Pekka Pietikainen





[Sound Cards]     [Computer Speakers]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp]     [Yosemite News]

Powered by Linux