Google
  Web www.spinics.net

Re: Samba--Connection Refused

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Before going too far with the material below, let me mention that the riddle of http://192.168.0.1 has been solved. I happened to keep a copy of the original /etc/services file and did a diff between it and the current one. You guessed it. The new one and old file had one difference--a missing reference to swat tcp/901 (or is it 901/tcp) in the new file. I put one in and away it went. Swat fired up via Mozilla without the use of webmin--just 192...blah.

My explanation is that the 3.0.9 samba debacle wasn't going to work under any circumstances (no 3.0.9 common, client, etc.), so that led to the original 901 difficulty. When I then installed 2.2.7a, it probably clobbered the file, which I'm guessing did not provide for the swat line in question. The reason for appearance of the line in the old file is I was following an online Linux networking book on the installation and use of Samba, I think I was instructed to put that line in services.

Since iptables -F had not apparent effect on the 901 problem, I took this to mean it didn't help. Hard to say though. I had rebooted afterwards to check any 'clearing/flushing'.

I can try out your suggestions below, but I have a feeling this part of the puzzle is solved. I can definitely get into swat.

The online book I'm referring to is at <http://www.linuxhomenetworking.com/>. In the TOC, click on Chapter 10 for Samba. I started down this path until I got to about page 10 where the 901 problem surfaced. If I follow this book, it looks like I have a few hours to get this all together.

I still have a few doubts about swat though. I tried setting the Global WORKGROUP via swat in the latest (192.168.0.2:901) access and to the swat access via webmin (see one of my last two posts) and it would not allow me to "set default". At least, it appears that way. Maybe the appropriate file has boluxed permissions.

In one of my recent two posts, I mentioned a possible firewall problem. In using webmin, it allows me to see the firewall settings, and it appears they are open both coming and going. However, as I post this, I"m on XP Pro and I don't see any other computers connected to me. I'll check the cable here in this room and reboot. This ethernet gets touchy sometimes.

Thanks for hanging in there on this. Who knows maybe it will work after all. :-)


-- Shrike-list mailing list Shrike-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/shrike-list

[Fedora Users]     [Centos Users]     [Kernel Development]     [Red Hat Install]     [Red Hat Watch]     [Red Hat Development]     [Red Hat Phoebe Beta]     [Yosemite Forum]     [Fedora Discussion]     [Gimp]     [Stuff]     [Yosemite News]

Powered by Linux