Google
  Web www.spinics.net

Re: compiling problems

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Wed, 2003-04-02 at 04:32, Matthias Saou wrote:
> Paul Dorneanu <spooky@xxxxxxxxx> wrote :
> 
> > I am trying to compile mod_ssl for apache 1.3.27, but I get the 
> > following error, that it doesn't find krb5.h in /usr/include/openssl
> > Yes, I do have krb5-devel installed, and there is an krb5.h in 
> > /usr/kerberos/include/
> > I've tried a symlink/hardcopy but that doesn't work either.
> > 
> > kssl.h includes krb5.h...
> > 
> > what should I do, or I'll just try to compile openssl/modssl without 
> > krb5.... ?!?
> 
> I has this problem trying to recompile sylpheed with SSL support on Shrike
> too. Here's a workaround:
> 
> if pkg-config openssl; then
>         CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
>         LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
> fi
> 
> Then if should work... (adapt if necessary).

Yes, this problem is *very *annoying. At the moment I can't even compile
libneon, even with adding the correct include flags for krb5.h,
something about the preprocessor rejecting the file or something like
that. Anyway, it's very annoying that every single OpenSSL package I've
tried so far now needs this additional kerberos stuff. I don't even use
kerberos.

Bleh.

-- 
Shawn <drevil@xxxxxxxxxxxx>
http://www.warpcore.org/





[Fedora Users]     [Centos Users]     [Kernel Development]     [Red Hat Install]     [Red Hat Watch]     [Red Hat Development]     [Red Hat Phoebe Beta]     [Yosemite Forum]     [Fedora Discussion]     [Gimp]     [Stuff]     [Yosemite News]

Powered by Linux