Google
  Web www.spinics.net

Re: viewing/editing files at SMB locations

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thanks a stack for all the  help! much appreciated.

The command 

# /usr/bin/sudo /usr/bin/smbmount //maxxsrv/maxxess /mnt/smbmnt -o
username=jason,password=jason,gid=501,uid=500,fmask=664,dmask=755

worked nicely. The man page for smbmount is wrong, because there
it talks about using -u and -g, which don't work. 

Here is the line I put in my /etc/sudoers file (Type in 'visudo' as
root ) :

%users  ALL=/usr/bin/smbmount,/usr/bin/smbumount,/sbin/fuser,  
NOPASSWD: ALL

I edited /etc/group and added myself to the group 'users'.
The 'fuser'command is useful for killing any processes attached
to the SMB mount when I am tring to un-mount it.

Jason


/usr/bin/sudo /usr/bin/smbmount  //maxxsrv/maxxess /mnt/smbmnt -o 
> username=jason,password=jason,gid=501,uid=500,fmask=664,dmask=755

On Mon, 2003-10-20 at 18:14, H M Kunzmann wrote: 
> > I have enabled myself to use root passwords so that I don't have to
> > su first. 500 and 501 are my UID/GID numbers respectively.
> > What I find interesting is that even although I specifically state
> > that the mounted files/directories are to be owned by me, the files
> > still get owned by root, which means I can read the share but 
> > can't write to it as a normal user. Is there anyway I can force
> > the smb filesystem contents to be owned by me once mounted?
> 
> Try gid and uid.
> You can also use fmask and dmask to set permissions...
> 
> # /usr/bin/sudo /usr/bin/smbmount  //maxxsrv/maxxess /mnt/smbmnt -o
> username=jason,password=jason,gid=501,uid=500,fmask=664,dmask=755
> 
> > B.T.W. This share is a Windows server shared by all of the employees
> > here. I wanted to be more specific by mounting the share 
> > ..maxxsrv/Staff Directories/Jason, but the smbmount command could
> > not find that share, and it does exist! I tried quoting "Staff
> > Directories" and that didn;t work either. I have been at this for over 2
> > hours now and still no joy. Any suggestions?
> 
> You can't mount ..maxxsrv/Staff Directories/Jason since it's not a
> share, it's a subdirectory of a share. Perhaps you can create the mount
> to the share, and then create a soft link to the subdirectory you want
> to use ?



-- 
Psyche-list mailing list
Psyche-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/psyche-list

[Fedora General Discussion]     [Red Hat General Discussion]     [Centos]     [Kernel]     [Red Hat Install]     [Red Hat Watch]     [Red Hat Development]     [Red Hat 9]     [Gimp]     [Yosemite News]

Powered by Linux