Google
  Web www.spinics.net

RE: New Monitor

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



-----Original Message-----
From: redhat-install-list-bounces@xxxxxxxxxx
[mailto:redhat-install-list-bounces@xxxxxxxxxx] On Behalf Of Brenda Radford
Sent: Wednesday, February 25, 2009 4:40 PM
To: 'Getting started with Red Hat Linux'
Subject: RE: New Monitor



-----Original Message-----
From: redhat-install-list-bounces@xxxxxxxxxx
[mailto:redhat-install-list-bounces@xxxxxxxxxx] On Behalf Of Rick Stevens
Sent: Wednesday, February 25, 2009 4:35 PM
To: Getting started with Red Hat Linux
Subject: Re: New Monitor

Brenda Radford wrote:
> 
> -----Original Message-----
> From: redhat-install-list-bounces@xxxxxxxxxx
> [mailto:redhat-install-list-bounces@xxxxxxxxxx] On Behalf Of Rick Stevens
> Sent: Wednesday, February 25, 2009 4:04 PM
> To: Getting started with Red Hat Linux
> Subject: Re: New Monitor
> 
> (bunch of stuff snipped)
> (Brenda said:)
> 
>> fdisk -l
>>
>> Device  boot    start   end     ID      system
>>
>> /dev/hde1       *       1       13      83      Linux
>> /dev/hde2               14      9729    8e      Linux LVM
>>
>> lvscan
>>
>> inactive        /dev/VolGroup00/LogVol00        [72.62GB]       inherit
>> inactive        /dev/VolGroup00/LogVol01        [1.75GB]        inherit
>>
>>
>> e2fsck /dev/<vgname>/<lvname>
>>       /dev/VolGroup00/LogVol00
>>         /dev/VolGroup00/LogVol01
>> I got this error message for both:
>>
>> No such file or directory while trying to open
>> The superblock could not be read or does not describe a correct ext2
>> filesystem. If the device is valid and it really contains an ext2 file
>> system (and not swap or ufs or something else), then the superblock is
>> corrupt and you might try running e2fsck with an alternate superblock:
>> E2fsck -b 8193 <device>
>>
>> Linux rescue gave me this:
>> You don't have any Linux partitions.
>>
>> The chroot /mnt/sysimage
>> And cat /etc/fstab also failed. No such file or directory
>>
>> Nothing wonderful happened when it rebooted.
>>
>> Now what do I do? Do I have to start over with a fresh install?
>> This reminds me of a blue screen in Windows. I had one of those last
>> January.
>>
>> Thanks,
>> Brenda
>>
>>  
>>
>> Bob or Rick may have a different take. I say if you have nothing to lose
>> then why not do a fresh install. Still in reviewing this post it seems
> some
>> part of the file systems is hosed. If a recovery option exists, as a
>> tech-guy
>> I would pursue it just for the learning experience. From a sys admin
point
>> of
>> view with the goal of having a running box do a fresh install. Assuming
no
>> data or apps are needed from the existing install. 
> 
>> I'd tend to agree.  There's something very odd here.  The fdisk -l shows
>> Linux partitions on /dev/hde?  You'd have to have at least five IDE
>> drives to get out there, and Linux now treats all drives as SCSI so they
>> should show up as /dev/sde (not /dev/hde) with any fairly recent kernel.
>> 
>> You could, theoretically, do an "fsck /dev/hde1" as it's a regular
>> partition with a filesystem on it.  Do NOT fsck /dev/hde2 as that's an
>> LVM volume.
>> 
>> The rescue disk should have found that stuff and activated your volume
>> groups.  You can try it again by going into rescue mode and entering
>> "vgchange -ay" to activate the volume groups.
>> 
>> Going back to the initial problem, a message such as "FS: can't find
>> ext 3 filesystem on dev dm-0" smells more like we have a software RAID
>> here and it somehow is degraded or the RAID modules aren't loaded in the 
>> initrd image. A device such as dm-0 is a software RAID volume.
>> 
>> Brenda, was this configured on a software RAID?
> 
> 
> No RAID configuration. This box has four hard drives in it, but they are
not
> cabled.

How do you mean?  No data cables or no power cables?  If they still have
data cables but no power cables, that's bad and they can hang the bus.

Tell you what, can you give us a full rundown on the system?  Things
like CPU type (32- or 64-bit), amount of RAM, video card type, numbers
and types of drives, how they're connected and what you think you have
on them now, any external devices (USB, etc.) and which operating
systems you're trying to work with.
----------------------------------------------------------------------
- Rick Stevens, Systems Engineer                      ricks@xxxxxxxx -
- AIM/Skype: therps2        ICQ: 22643734            Yahoo: origrps2 -
-                                                                    -
-     Is that a buffer overflow or are you just happy to see me?     -




No data cables AND no power cables. They are just in the case. They were not
connected when I did the install, I do not think.








I have good news to report. Linux rescue did not work again, so I decided to
try the Live CD (Knoppix) to see if I could activate the Logical Volumes. It
worked. I then ran e2fsck on the LV's and told it to fix everything it found
wrong, and it worked. I am able to boot and have now updated the box to RHEL
AS 4 Update 7. 

As for the hde thing, I seem to remember that I installed on a master while
I had a slave drive that had Red Hat on it. The slave drive was not mounted
automatically; I had to mount it to access the data on it. I must have
unplugged it at some point after the fire (I cannot remember because that
motherboard was installed into a new case), but none of the filesystem from
the last install was on that drive. I might have unplugged it when I put the
DVD burner in there on an IDE controller card last summer or fall, but I
cannot be sure. I do not think that had anything to do with the box not
booting last week, but I could be wrong, Rick. I do not know how the
filesystem became corrupted. I do not know whether to trust that hard drive
or not.

Thanks again to all who replied to my posts, especially when you were sure I
did not know what I was doing. The new monitor is working fine on a DVI
cable.

Now if I could just get the HP printer to work . . . Something about HPLIP
not being compatible with HPOJ, and errors related to qt while trying to
install PyQt 4.x (python configure.py fails). I am in over my head on this
one.

Thanks,
Brenda




_______________________________________________
Redhat-install-list mailing list
Redhat-install-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/redhat-install-list
To Unsubscribe Go To ABOVE URL or send a message to:
redhat-install-list-request@xxxxxxxxxx
Subject: unsubscribe

[Red Hat Kickstart]     [Fedora Users]     [Red Hat General]     [Red Hat Development]     [Samba]     [Kernel]     [Kernel Newbies]     [Hot Springs]     [Yosemite News]

Powered by Linux