[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

canon printer not working with canon driver



Hi,
I am using canon printer and it is working fine with  my Redhat linux 7.3 system.
It prints both text and postscript files without any error.

Now I try to print from other target board containing DiskOnChip.

I have copied all printer related files to diskonchip. (lpd,lpr,...,usr/share/printconf, usr/share/ghostscript, usr/share/foomatic, /usr/bin/gs, ...).
I copied /usr/lib/Omni/libomni.so, /usr/lib/Omni/libCanon_BJ*.so to my target board.

With that board, the printer is working fine if I configure "Text only Printer" in printconf-tui.
But it is not working with Canon BJ F200 Omni driver with the board.

The details are:
In Target board, with "printconf-tui", first I chose "text Only Printer" as follows.

/usr/bin/printconf-tui 
I created a new queue with name "text"
I chose "Text Only Printer" in "Queue driver" option.
It created the queue with following details:
 Type : Local Printer Device
 Device : /dev/lp0
 Driver : Text Only Driver

Then I printed using
   lpr -Ptext /etc/printcap.
The file was printed correctly.

Next I created  a Queue  with name "Canon"
I chose " Canon -> BJ F200 -> Omni " in Queue driver option.
It created the queue with following details:
 Type : Local Printer Device
 Device : /dev/lp0
 Driver : Canon BJ F200 Driver 

Then I tried with 
lpr -PCanon /etc/printcap.
But the printer is not at all responding.
And I am also not getting any error message.

What is wrong in the configuration?
Please help.
Thanks,
vijaibaskar



_______________________________________________
Redhat-devel-list mailing list
Redhat-devel-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/redhat-devel-list

[Kernel Newbies]     [Red Hat General]     [Fedora]     [Red Hat Install]     [Linux Kernel Development]     [Yosemite News]

Powered by Linux