How to copy/replicate files w/o changing the access time?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

I need to migrate terabytes of data from one NAS (NetAPP) to a new NAS
(HNAS). We are also implementing an archive solution with the new NAS that
will archive files that haven't been accessed in X amount of time. I can't
seem to find a way to replicate the data w/o changing the access times on
the destination copy. I've tried rsync and cpio and both end up modifying
the destination copy's access time. I've even tried reading the source from
a read-only snapshot.

So far the only way I can get these files on the new NAS w/o updated access
times is using netbackup/NDMP but the volume of data is far to great for
this approach. I'm wanting to use rsync or some other tool that has
incremental capabilities so I can start moving the data online w/o downtime,
and then take a small outage to do a final sync and then cutover.

Anyone have any suggestions? I have linux and solaris hosts at my disposal.
So far the behavior has been the same from Solaris 10 and RHEL 5 clients.

redhat-list mailing list
unsubscribe mailto:redhat-list-request@xxxxxxxxxx?subject=unsubscribe

[CentOS]     [Kernel Development]     [Red Hat Install]     [PAM]     [Fedora Users]     [Red Hat Development]     [Red Hat 9]     [Big List of Linux Books]     [Linux Admin]     [Photo Sharing]     [Hot Springs]     [Gimp]     [Asterisk PBX]     [Yosemite News]     [Red Hat Crash Utility]

Add to Google Powered by Linux