Re: RHEL5.3 x64 first boot problem on FTS RX300 S6 - grub not loading - SOLVED

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]




W dniu 23.06.2011 08:31, ext Ostrowski, Tomasz (NSN - TH/Bangkok) pisze:


W dniu 23.06.2011 00:39, ext Grzegorz Witkowski pisze:
On Tue, 2011-06-21 at 15:14 +0200, Ostrowski, Tomasz (NSN - TH/Bangkok)
wrote:
Hello All,

I just wonder if it is known case that right after installation of RHEL
5.3 x64 on FTS RX300 S6 the grub is even not loading.
What I've done is standard RAID (mirroring) configuration in the LSI
menu (CTRL + C during post)
hd1 + hd3 = mirror1
hd2 + hd4 = mirror2

I've booter from DVD installed like via gui (no lvm) everything on sda:
/boot    ext3    200MB   (sda1)
/    ext3    40960MB    (sda2)
Swap    ext3    20480MB
/opt    ext3<Free space>
/var    ext3    10240MB
/usr    ext3    10240MB
/home    ext3    20480MB
/tmp    ext3    20480MB

Then after reboot when the server wants to boot the screen becomes
black, and there is no grub.

I've booted to rescue mode with rhel DVD, performed grub installation
"setup (hd0) (hd0,0)" the result was successful but still after reboot
the screen is black :(.

Do you have any hints about this?

Do you think that using dd to load stage1 directly into /dev/sda could
be good idea?

Regards
Tomek



--
Tomasz Ostrowski
Nokia Siemens Networks Ltd, Thailand
OPS Integrated OEM and Digital Supply/APAC
Mobile NEW: +66 824 85 87 70
Time Zone: GMT+7

Hi Tomek,

Have you check on your controller if there is any option to select which
virtual disk should be a boot device?
Some controllers offer that option.
> From your post it looks you setup 2xRAID1 VDs. If non of them or the
wrong one has the boot flag set the system won't boot from this VD.
I do not know this platform, but have you got a BIOS boot menu
available? If yes, have you tried to select it? Are you sure you are
booting from the correct device?

Kindest regards,
Ges
--------------------------------------------------------------
01000111 01100101 01110011 01100011 01100001 01110000 01100101
http://counter.li.org #239224 Registration 2001-10-29 07:19:32
         -= GNU/Linux - The Experience of Freedom =-

HI Grzegorz,

The LSI controller has very limited configuration options. Like create RAID and nothing more. I haven't see any option for boot flag in the LSI controller. In the BIOS the created VD's are visible. I've even tried to manually force in boot-menu to boot from the VD but no luck. I think it is some kind of bug, Ive found some web pages during googling. Make a query "grub installation problem on LSI mirror". But make it on google.com on .pl the results are different.
Unfortunately nothing helpful for me.

One more thing putting stage1 by dd on the drive is not healthy, I've expected that it will erase partitions info but just wanted to try :)

Regards
Tomek


Hi All,

Finally a halfway solution, not full because the servers been taken away to different department.

What I did is make the installation by two scenarios:
1. Create 1 mirror + 2 hot spares, then only one lun is visible in BIOS. (you can naturaaly remove 2 HDD and leave only a mirror) The funny think is that this LSI controller is i think some kind of weird (SW not HW?) - If you have already installed OS and partitioned whole disc you can't create mirroring by making a resync to the second sub-mirror. The controller is complaining that there is not enough disc space to create the mirror - smells like SW solution. But going back to the main topic, now I was having only one HDD visible in BIOS. I've made the installation and no problems with GRUB :) Everything went fine with firs boot etc.

2. Create RAID 5 by using 4 disks. Then only one lun is visible in BIOS.
By this scenario installation and booting was also ok. No problem with GRUB.

So it looks like that GRUB is having some headache if it seas 2 luns (HDDs) and making some mistake that if it is referring to (hd0) it thinking about (hd1) and vice versa. - This thought I was able to find while googling to solve the problem, unfortunately I can't remember where.

I didn't had time to investigate more on this because the HW had to be shipped out.

Regards
Tomek

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@xxxxxxxxxx?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list


[Index of Archives]     [CentOS]     [Kernel Development]     [Red Hat Install]     [PAM]     [Fedora Users]     [Red Hat Development]     [Red Hat 9]     [Big List of Linux Books]     [Linux Admin]     [Photo Sharing]     [Hot Springs]     [Gimp]     [Asterisk PBX]     [Yosemite News]     [Red Hat Crash Utility]

  Powered by Linux