Re: sony-laptop driver: Volume keys on Sony Vaio TX3 don't work

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Mon, Oct 17, 2011 at 01:17:00AM +0200, John Hughes wrote:
> On 10/16/2011 11:50 PM, Valdis.Kletnieks@xxxxxx wrote:
> >
> >And let me guess - two phase hotkey decoding is sufficiently weird that
> >nobody wants to actually fix *that* code, right? (Rhetorical question, I
> >already know the answer to that one).
> Ok, what is "two phase hotkey decoding?"

basically the driver receives in IRQ, reads from the IO port a value
that turns out to be a generic value that means "got a hotkey" and needs
to write one more command to the IO port and wait for another IRQ that
potentially has the information about what hotkey was pressed.

The part we're currently missing is what to write to the IO port for
some models.

See type3_handle_irq in the source and type3_events: most of those with
data=0x05 require extra handling that we are not doing. 
On the second IRQ you get some data=0x31 and the actual event.

Hope it's clearer.
-- 
mattia
:wq!
--
To unsubscribe from this list: send the line "unsubscribe platform-driver-x86" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]    [Yosemite Photos]    [Free Online Dating]     [Linux Kernel]     [Linux SCSI]     [XFree86]

Add to Google Powered by Linux