[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HELP! Nusoap client does not post any parameters!



I am sitting here since 2 days and cant get this to work. Help.

client file:
<?php
// Pull in the NuSOAP code
require_once('nusoap.php');
// Create the client instance
$client = new
nusoap_client('http://betaservices.membersolutions.com/Business.PartnerService/svc/slim.svc?wsdl',
true);
// Check for an error
$err = $client->getError();
if ($err) {
    // Display the error
    echo '<h2>Constructor error</h2><pre>' . $err . '</pre>';
    // At this point, you know the call that follows will fail
}
// Call the SOAP method
$result = $client->call('CreateAccount',array('ClientID'=>'999999',
'MerchantClientID' => '000000', 'ClientPassword' => 12345678901236456789',
'FirstName' => 'Test', 'LastName' => 'Testington', 'MI' => 'T',
'StreetLine1' => '9999 Test Ave', 'StreetLine2' => 'STE 111', 'City' =>
'Test City', 'StateProvince' => 'MA', 'Zip' => '00001', 'Email' =>
'test@test.te', 'Country' => 'USA', 'HomePhone' => '555 555 5555',
'WorkPhone' => '555 555 5554', 'ReferenceID' => 'gsdfg456r4etgfdg',
'ContractType' => '2', 'TotalPrice' => '2000.00', 'PaymentAmount' =>
'100.00', 'FirstPaymentDueDate' => '5/5/2011', 'PaymentFrequencyName' =>
'2', 'PaymentFrequencyValue' => '1'));
// Check for a fault
if ($client->fault) {
    echo '<h2>Fault</h2><pre>';
    print_r($result);
    echo '</pre>';
} else {
    // Check for errors
    $err = $client->getError();
    if ($err) {
        // Display the error
        echo '<h2>Error</h2><pre>' . $err . '</pre>';
    } else {
        // Display the result
        echo '<h2>Result</h2><pre>';
        print_r($result);
    echo '</pre>';
    }
}
// Display the request and response
echo '<h2>Request</h2>';
echo '<pre>' . htmlspecialchars($client->request, ENT_QUOTES) . '</pre>';
echo '<h2>Response</h2>';
echo '<pre>' . htmlspecialchars($client->response, ENT_QUOTES) . '</pre>';
// Display the debug messages
echo '<h2>Debug</h2>';
echo '<pre>' . htmlspecialchars($client->debug_str, ENT_QUOTES) . '</pre>';
?>

For some reason it does not pass on any parameters. Why would that be?
-- 
View this message in context: http://old.nabble.com/HELP%21-Nusoap-client-does-not-post-any-parameters%21-tp31300709p31300709.html
Sent from the Php - Soap mailing list archive at Nabble.com.


-- 
PHP Soap Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php



[PHP Home]     [PHP Users]     [Kernel Newbies]     [PHP Database]     [Yosemite]

  Powered by Linux