Installing php 5.2.9 with --enable-embed

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]




Hi,

I'm trying to install php 5.2.9 from source on OS X (10.5) with
--enable-embed turned on.

I get the same error listed in this bug:

http://bugs.php.net/bug.php?id=44462

I've applied the patch to remove the yytext duplicate symbols problem,
but now I get an error when linking.  I've pasted the linking error
here:

http://pastebin.com/fe646d4f

The missing .o files seem to be there, just not where the command
points.  For example, the command points at "sapi/cli/getopt.o" and
I've found that .o file in "./sapi/cli/.libs/getopt.o".

Here is a diff of how I patched 5.2.9:

http://pastebin.com/f2793c8d7

Any help would be greatly appreciated.  Thanks!

-- 
Aaron Patterson
http://tenderlovemaking.com/

[PHP Home]     [PHP on Windows]     [Programming PHP]     [Kernel Newbies]     [Why pay for online dating?]     [PHP Users]     [PHP Classes]     [Postgresql]     [PHP Books]     [PHP Databases]     [PHP SOAP]     [PHP Books]

  Powered by Linux