Search Postgresql Archives

Re: Missing row after update

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



On Jun 7, 12:44 pm, adrian.kla...@xxxxxxxxx (Adrian Klaver) wrote:
> On 06/07/2012 06:57 AM, Dinsdale wrote:
>  > Hi there. I am new to Postgresql but very familiar with RDBMS. We are
>  > running 8.4 on windows serer 2008 r2. I was updating a record through
>  > pgAdmin and was being an a$$ and pressed the run button multiple times
>  > and then the record just disappeared. Update query:
>  >
>  > update jaas_login set password=md5(login_name || ':' || realm_name ||
>  > ':Password123'), has_logged_in = false, modified=now(),
>  > failed_attempts=0 where login_name like 'CompanyAdmin@%';
>
> So just to be clear the above was what was run multiple times?
>
>  >
>  > I cannot find the record at all so tried to re-insert it and the query
>  > just runs and runs and runs.
>
> Select * from jaas_login where login_name like CompanyAdmin@%'; shows
> nothing?
>
> What is your INSERT query?
>  >
>  > We thought we had backups of this DB but all we have are dump files
>  > and I really really don't want to have to restore if I can avoid it. I
>  > find it hard to believe that a db as advanced as postgresql will just
>  > "lose" data and there has to be some explaination for where the record
>  > is.
>
> I tend to doubt it just disappeared.
>  >
>  > Any help would really save my butt. Thanks
>  >
>  > Dinsdale
>  >
>
> --
> Adrian Klaver
> adrian.kla...@xxxxxxxxx
>
> --
> Sent via pgsql-general mailing list (pgsql-gene...@xxxxxxxxxxxxxx)
> To make changes to your subscription:http://www.postgresql.org/mailpref/pgsql-general

I tried every select query I could think of including with no where
clause and simply searching manually for the record but it was just
not there. I had someone else verify this as well. I didn't think it
could just disappear either. We finally decided to use the dump file
and re-create the database but just before that I tried a backup and
got an error about a missing attribute on relid xxxx. Someone with
more Postgres experience said that the table was corrupted and i
should just rebuild, so we did.

Please note that I CANNOT reproduce this in our QA! I think maybe the
issue noted by steve below may be the problem.

-- 
Sent via pgsql-general mailing list (pgsql-general@xxxxxxxxxxxxxx)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-general



[Postgresql Jobs]     [Postgresql Admin]     [Postgresql Performance]     [Linux Clusters]     [PHP Home]     [PHP on Windows]     [Programming PHP]     [Kernel Newbies]     [PHP Classes]     [Find Someone Nice]     [PHP Books]     [PHP Databases]     [Postgresql & PHP]     [Yosemite]

Add to Google Powered by Linux