Search Postgresql Archives

Re: Compile docs on ArchLinux

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



On Wed, Apr 18, 2012 at 01:25:14PM +0900, Michael Paquier wrote:
> Hi all,
> 
> Under Arch, I am not able to compile Postgres docs.
> 
> By having a look at config.log, it cannot find the docbook folder:
> configure:29356: checking for DocBook V4.2
> onsgmls:/etc/xml/catalog:2:78:E: name expected
> onsgmls:/etc/xml/catalog:2:18:E: cannot find "PUBLIC"; tried
> "/etc/xml/PUBLIC", "/usr/share/sgml/PUBLIC", "/usr/share/xml/PUBLIC"
> onsgmls:conftest.sgml:1:54:W: cannot generate system identifier for public
> text "-//OASIS//DTD DocBook V4.2//EN"
> 
> The stylesheets are correctly set up.
> configure:29391: checking for DocBook stylesheets
> configure:29427: result: /usr/share/sgml/stylesheets/dsssl/docbook
> 
> It looks that the correct packages are installed:
> $ pacman -Q | grep docbook
> docbook-dsssl 1.79-3
> docbook-sgml 4.5-1
> docbook-xml 4.5-5
> docbook-xsl 1.76.1-2
> docbook2x 0.8.8-11
> Well, docbook-sgml 4.5 is installed, not 4.2, but I would suppose that it
> is enough.
> 
> Is it necessary to setup a variable like DOCBOOKSTYLE?
> Thanks in advance!

I don't think it will be solved - I reported it in november 2009
: http://archives.postgresql.org/pgsql-general/2009-11/msg00325.php
then asked on serverfault
: http://serverfault.com/questions/83206/how-to-build-docbook-4-2-docs-on-arch-linux

but the general idea (for now) is that I simply download ready made
docs from daily snapshots.

Best regards,

depesz

-- 
The best thing about modern society is how easy it is to avoid contact with it.
                                                             http://depesz.com/

-- 
Sent via pgsql-general mailing list (pgsql-general@xxxxxxxxxxxxxx)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-general


[Postgresql Jobs]     [Postgresql Admin]     [Postgresql Performance]     [Linux Clusters]     [PHP Home]     [PHP on Windows]     [Programming PHP]     [Kernel Newbies]     [PHP Classes]     [Find Someone Nice]     [PHP Books]     [PHP Databases]     [Postgresql & PHP]     [Yosemite]

Add to Google Powered by Linux