Re: phpinfo(): postgresql versions' mismatch

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Hi Michael,

Thanks for comments!

On Fri, Feb 09, 2007 at 11:31:29AM +0200, Mihail Mihailov wrote:
I have recently found out that  PHP libpq Version reported by
phpinfo() doesn't match the Actual PGSQL Version on the server.
I suspect this is the reason why some of postgresql queries do not run
via web interface and run without any problem via psql.


Only some PHP queries don't run?  What's different about those that
run and those that don't?
At first everything seemed to work fine. Connection works, queries run.
So far I have found only one query, which worked in postgres 7.4 and doesn't seem to work now. It is a SELECT query with LIMIT and OFFSET clauses. The first query with OFFSET 0 worked, but the second with OFFSET N returned an empty recordset. I suspected that it has to do with php because the same query works fine in psql environment.

Do the queries that don't run fail with
an error message?  If so, what's the exact message?  What do the
PostgreSQL logs show for the failed queries?  You might need to
adjust settings like log_min_error_statement in postgresql.conf to
get useful log entries.
Actually, these queries do not fail they just don't return any data.
Do you think it's more likely a bug in the script?

If you ever upgrade PHP to use 8.x libraries instead of 7.4 libraries,
beware that some prepared queries that used to work might start
failing.
So, you think it is not a good idea to make php use the 8.x libpq?
Is the 7.4 libpq quite compatible with postgres 8.1?
Does it affect the speed?

Mihail Mihailov


[Postgresql General]     [Postgresql Admin]     [PHP Users]     [PHP Home]     [PHP on Windows]     [Kernel Newbies]     [PHP Classes]     [PHP Databases]     [Yosemite Backpacking]     [Postgresql Jobs]

Add to Google Powered by Linux