[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Re: pam_cracklib build problem



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thorsten,

config.log shows the following:
mporwit-linux[Linux-PAM-0.99.6.3]% grep crack config.log
  $ ./configure --prefix=/tmp/pam
-
--with-cracklib=/home/mporwit/work/Sapphire.meta/linux/i386/RPM/centeris-cracklib/staging/usr/centeris
configure:21920: checking for FascistCheck in -lcrack
configure:21955: gcc -o conftest -g -O2 -W -Wall -Wbad-function-cast
- -Wcast-align -Wcast-qual -Wmissing-declarations -Wmissing-prototypes
- -Wpointer-arith -Wreturn-type -Wstrict-prototypes -Wwrite-strings
- -Winline -Wshadow   -Wl,--as-needed -Wl,-O1 conftest.c -lcrack   >&5
/usr/lib/gcc/i586-suse-linux/4.1.2/../../../../i586-suse-linux/bin/ld:
cannot find -lcrack
configure:24191: checking crack.h usability
conftest.c:79:19: error: crack.h: No such file or directory
| #include <crack.h>
configure:24249: checking crack.h presence
conftest.c:46:19: error: crack.h: No such file or directory
| #include <crack.h>
configure:24319: checking for crack.h
config.status:780: creating modules/pam_cracklib/Makefile
ac_cv_header_crack_h=no
ac_cv_lib_crack_FascistCheck=no

So yeah, it is not finding a usable cracklib. However, I still don't
know how to tell configure where to pick it up from:
mporwit-linux[Linux-PAM-0.99.6.3]% grep crack configure.in
AC_CHECK_LIB([crack], [FascistCheck], LIBCRACK="-lcrack", LIBCRACK="")
AC_CHECK_HEADERS(crack.h)
        modules/pam_access/Makefile modules/pam_cracklib/Makefile \

As I already mentioned, --with-cracklib=<cracklib_prefix> does not
appear to be the right syntax.

Thorsten Kukuk wrote:
> On Wed, Feb 14, Marcin Krzysztof Porwit wrote:
> 
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>>
>> Thorsten,
>>
>> I didn't post the message because it was generated after I mucked around
>> with the Makefile manually, so I assume it was a result of something I
>> did. I do have cracklib on my system -- how do I tell configure to use
>> it? Standard options like --with-cracklib=<cracklib_prefix> don't appear
>> to do the trick...
> 
> Check the configure output and config.log why configure thinks your
> cracklib version is unuseable.
> 
>   Thorsten

- --
Marcin Krzysztof Porwit
mporwit@xxxxxxxxxxxx

#include <stddisclaimer.h>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFF02Sb4OZU6cX5VBERAmkwAJ9+M3gNBeqtVd1tA4wbwxReLskzrwCfapyM
fBZ3ScuHEx37oqQjMlMPHP0=
=NRbx
-----END PGP SIGNATURE-----

_______________________________________________
Pam-list mailing list
Pam-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/pam-list

[Fedora Users]     [Kernel]     [Red Hat Install]     [Linux for the blind]     [Gimp]

Add to Google Powered by Linux