Re: Sending ICMP echo request out

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi ,

I have following setup with routing table as shown below:

+-----------------------+
|    System-1      |
|     "client"         |
|------------------------|
|  192.168.11.5   |
+----------------------+
       |
       |
+------+-----+
|   Switch   +----------------------+
+------+-----+                        |
       |                                 |
       |                       +-------------------------+
       |                        |  192.168.11.1      |
       |                        |---------------------------|
       |                        |     Router            |
       |                        |-------------------------- |
       |                        |   192.168.12.1     |
       |                       +--------------------------+
       |                                    |
       |                                    |
+------------------------+                |
|  192.168.11.6      |                |
|--------------------------|                |
|   System-2        |                |
|--------------------------|                |
|   192.168.12.6    |                |
|                          |----------------+
+------------------------+

Routing table details of setup
------------------------------------------
System-1
-----
$route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.11.0    0.0.0.0         255.255.255.0   U     1      0        0 eth1
0.0.0.0         192.168.11.1    0.0.0.0         UG    0      0        0 eth1


Router
-----------
$route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.12.0    0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.11.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0


System-2
------
$route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.12.0    0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.11.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.12.1    0.0.0.0         UG    0      0        0 eth1


When I do ping from system-1 192.168.11.5 to system-2 192.168.12.6 ,
ping echo packet is reaching on system-2 through NIC 192.168.12.6 but
system is not sending any response to 192.168.11.5 using either of NIC
i.e 192.168.11.6 or 192.168.12.6 ? Why this is happening ? Can you
help me ?

I have observed same type of symtoms when I do SSH from 192.168.11.5
to 192.168.12.6

FYI,
ip_forwarding is enable on router and iptables are no configured on
any of system .

Thanks,
Anil
--
To unsubscribe from this list: send the line "unsubscribe netfilter" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux Netfilter Development]     [Linux Kernel Networking Development]     [Linux Networking Development]     [Linux Kernel Development]     [Linux Resources]     [LARTC]     [Bugtraq]     [Consulting]     [Free Internet Dating]     [Yosemite Forum]     [Photo]

Add to Google Powered by Linux