Google
  Web www.spinics.net

DVD playback error (latest SVN)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tue, Jun 01, 2010 at 08:00:59AM +0200, Reimar D?ffinger wrote:
> On Tue, Jun 01, 2010 at 12:18:38AM -0500, Stephen Stocker wrote:
> > This happens with either mplayer dvdnav://1 or dvd://1 or
> > dvd://1-14. I've now tried reverting libdvdcss to r31154, which
> > works fine. Then tried r31157, and I get the same error.

> > Could you please check which of r31155, r31156 and r31157 broke it
> > exactly?

> I think there's a typo, could you try
> Index: libdvdcss/libdvdcss.c
> ===================================================================
> --- libdvdcss/libdvdcss.c       (revision 31294)
> +++ libdvdcss/libdvdcss.c       (working copy)
> @@ -367,7 +367,7 @@
>      if( dvdcss->b_ioctls )
>      {
>          i_ret = _dvdcss_test( dvdcss );
> -        if( i_ret == -2 )
> +        if( i_ret == -3 )
>          {
>              /* Scrambled disk, RPC-II drive, no region set: bail out */
>              free( dvdcss->psz_device );

On Tue, Jun 01, 2010 at 08:00:59AM +0200, Reimar D?ffinger wrote:
  > On Tue, Jun 01, 2010 at 12:18:38AM -0500, Stephen Stocker wrote:
  > > This happens with either mplayer dvdnav://1 or dvd://1 or
  > > dvd://1-14. I've now tried reverting libdvdcss to r31154, which
  > > works fine. Then tried r31157, and I get the same error.
  >
> > Could you please check which of r31155, r31156 and r31157 broke it
> > exactly?

> I think there's a typo, could you try
> Index: libdvdcss/libdvdcss.c
> ===================================================================
> --- libdvdcss/libdvdcss.c       (revision 31294)
> +++ libdvdcss/libdvdcss.c       (working copy)
> @@ -367,7 +367,7 @@
>      if( dvdcss->b_ioctls )
>      {
>          i_ret = _dvdcss_test( dvdcss );
> -        if( i_ret == -2 )
> +        if( i_ret == -3 )
>          {
>              /* Scrambled disk, RPC-II drive, no region set: bail out */
>              free( dvdcss->psz_device );

I tried the patch, and it stopped the drive I/O errors. But now I'm just 
getting the following:

MPlayer SVN-r31297-3.3.6 (C) 2000-2010 MPlayer Team
/home/lpar/.mplayer/subfont.ttf doesn't look like a bitmap font description, ignoring.
Cannot load bitmap font: /home/lpar/.mplayer/subfont.ttf

Playing dvdnav://1.
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
Couldn't open DVD device: /dev/dvd (No such file or directory)
No stream found to handle url dvdnav://1
libdvdnav: Using dvdnav version MPlayer-custom
libdvdnav: vm: failed to open/read the DVD


Exiting... (End of file)

And trying dvd://1, basically the same thing, with the "No such file or 
directory". I'm completely lost. Thanks for the help, anyway. :)


-- 
Hope, Despair and the Triumph of Life
          http://www.hdtl.org
   Abuse Prevention/Survivor Support


[Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]    [Yosemite Photos]    [Free Online Dating]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Devices]

Add to Google Powered by Linux