Re: Using NFS with HIGHMEM support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


HI:
 I'm encountered pretty much the same problem here
 I'm tracing with current 3.3-rc4 branch(from ralf's tree)
 If I put rootfs at nand flash + highmem enabled, then execute problem may give
illegal instruction error, bus error, try it again may run success.
 but if I don't enable highmem, then problem is gone.
 any hints? thanks

Dennis

On Mon, Nov 28, 2011 at 4:37 PM, Jacky Lam <lamshuyin@xxxxxxxxx> wrote:
Hi,

   I am using mips-linux-3.0.4 with HIGHMEM enabled. Everything is working fine, but I find something strange that when I execute a statically-linked binary through NFS mounted directory. It will gives me an illegal instruction error or  SIGSEGV. If I run it again, the binary can run without problem. I have to reboot or drop all the vm cache in order to reproduce the error again.

  Also, if I run the binary in harddisk or dynamically link the binary, no problem will be found.

   Any suggestion to debug this problem? Thanks.

Jacky



[Linux MIPS Home]     [LKML Archive]     [Linux ARM]     [Linux]     [Git]     [Photo]     [Yosemite News]     [Linux SCSI]     [Linux Hams]

Add to Google Powered by Linux