[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

System Down - Adaptec raid failure



Hello-

I'm in fair bit of a pickle. One of my servers imploded on Friday. One of 
the disks in a mirror showed as failed and triggered the alarm on the 
Adaptec 2005s raid controller. In the past, I've been able to use raidutil 
aka dptutil to rebuild the mirror. If the drive broke the mirror again, 
I'd get a replacement and swap it out. Friday however, when I told the 
system to rebuild the mirror, it melted down and soon reached an unusable 
state where it locked up solid.

Fortunately the majority of the system is on tape and I can restore it. 
There are some files that ended up outside of the nightly backup routine 
that I'd like to recover if possible.

Currently the system is offline. I had a spare server that I brought up 
with the most critical services like dns, proxy and printing.

The dead box is Redhat v8 with an onboard Adaptec 2005s raid controller. 
There are six scsi disks. The first four are in a raid 10 setup and that 
is the array that is having trouble. It also happens to be the boot disks. 
The last two disks are in a mirror and they still report as good in the 
card bios.

The most important files are on the 2 disk mirror however I'd really like 
to get to /etc on the other disks if possible to help me in rebuilding my 
full dns, recover user accounts etc.

I've tried booting from a Redhat CD in rescue mode and giving it the dpt 
module from a floppy but it failed to find any linux partitions. I also 
tried a Knoppix CD but that didn't work either.

Any assistance is most appreciated.
_______________________________________________
LinuxManagers mailing list - http://www.linuxmanagers.org
submissions: LinuxManagers@xxxxxxxxxxxxxxxxx
subscribe/unsubscribe: http://www.linuxmanagers.org/mailman/listinfo/linuxmanagers

[Home]     [Kernel List]     [Linux SCSI]     [Video 4 Linux]     [Linux Admin]     [Yosemite News]     [Motherboards]

Powered by Linux