Re: n900: usb keyb and h-e-n

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Hi,

Thanks guys. I have extkbd installed now, but it doesn't solve it. Are there other small things to think about (which app, how long should I wait before type etc.)?


See attachment for log file

Greetz
Dirk

On 08/23/2011 06:22 PM, Paul Hartman wrote:
On Mon, Aug 22, 2011 at 8:55 AM, Dirk<schoappied@xxxxxxxxx>  wrote:
Hi,
Hi Dirk

I have such usb usb connector
http://www.dealextreme.com/p/usb-cable-coupler-extension-connector-2646
I have the same connector

Then I start h-e-n

First message: 'stopping BME'

Then I choose:
low speed hostmode
VBUS boost on
enumerate
connect usb-keybd to n900
mount
But nothing is happening ... when I try to type in a xterm.

I can't turn on Capslock.

Also mouse does nothing.
You don't mount a keyboard or mouse, so that step is not needed in
those cases (or any case, if you mount manually)

When I connect and mount a usb stick, it says
'unable to connect, no file system available'
I have not tried a keyboard or mouse with H-E-N, but I have used
several flash drives and external HDDs with no problems. Maybe tonight
when I am home I'll try to connect a keyboard.

Also try using an externally-powered USB hub.

Is this the right place to ask this question? It would be a big deal for me
if I got this working.
I was going to direct you to the H-E-N support thread at
talk.maemo.org but I see you're already there. :)
_______________________________________________
maemo-users mailing list
maemo-users@xxxxxxxxx
https://lists.maemo.org/mailman/listinfo/maemo-users

-------
[ 2538.624023] WARNING: at /home/builder1/maemo-fremantle-armel-extras-devel/work/kernel-power-2.6.28/drivers/usb/musb/musb_host.c:128 musb_h_tx_flush_fifo+0x94/0xcc()
[ 2538.624023] Could not flush host TX0 fifo: csr: 000a
[ 2538.624053] Modules linked in: vfat fat sd_mod scsi_mod iphb rfcomm panic_info_buff sco l2cap omaplfb ext3 pvrsrvkm jbd bridgedriver ipv6 g_file_storage uinput board_rx51_camera omap_previewer_hack omap34xxcam_mod isp_mod iovmm videobuf_dma_sg videobuf_core omap3_iommu iommu2 iommu dspbridge ssi_mcsaab_imp mmc_block phonet joydev cmt_speech omap_hsmmc wl12xx smc91x mii mac80211 crc7 omap_wdt omap_ssi hci_h4p nokia_av mmc_core cfg80211 tsc2005 bluetooth fmtx_si4713 adp1653 ad5820 smia_sensor et8ek8 bq27x00_battery leds_lp5523 rtc_twl4030 leds_twl4030_vibra smiaregs videodev v4l1_compat compat_ioctl32 power_supply tsl2563 lis302dl led_class v4l2_int_device twl4030_wdt rtc_core fuse
[ 2538.624298] [<c0030470>] (dump_stack+0x0/0x14) from [<c0057444>] (warn_slowpath+0x64/0x80)
[ 2538.624359] [<c00573e0>] (warn_slowpath+0x0/0x80) from [<c01e9a80>] (musb_h_tx_flush_fifo+0x94/0xcc)
[ 2538.624389]  r3:00000000 r2:c034453d
[ 2538.624389]  r6:d80ab100 r5:0000000a r4:0000000a
[ 2538.624420] [<c01e99ec>] (musb_h_tx_flush_fifo+0x0/0xcc) from [<c01ea950>] (musb_cleanup_urb+0xc0/0x10c)
[ 2538.624450] [<c01ea890>] (musb_cleanup_urb+0x0/0x10c) from [<c01eb154>] (musb_urb_dequeue+0x1dc/0x248)
[ 2538.624481] [<c01eaf78>] (musb_urb_dequeue+0x0/0x248) from [<c01cecbc>] (unlink1+0x108/0x114)
[ 2538.624511] [<c01cebb4>] (unlink1+0x0/0x114) from [<c01cfc58>] (usb_hcd_unlink_urb+0x9c/0xf8)
[ 2538.624542] [<c01cfbbc>] (usb_hcd_unlink_urb+0x0/0xf8) from [<c01d0b14>] (usb_kill_urb+0x84/0x14c)
[ 2538.624572]  r7:ca7fae80 r6:ca7fae80 r5:cf0a6000 r4:00000000
[ 2538.624603] [<c01d0a90>] (usb_kill_urb+0x0/0x14c) from [<c01d1d98>] (usb_start_wait_urb+0x80/0x120)
[ 2538.624633]  r6:00001388 r5:cf0a7e50 r4:00000000
[ 2538.624633] [<c01d1d18>] (usb_start_wait_urb+0x0/0x120) from [<c01d2018>] (usb_control_msg+0xc4/0xe8)
[ 2538.624664] [<c01d1f54>] (usb_control_msg+0x0/0xe8) from [<c01cad0c>] (hub_port_init+0x3d8/0x634)
[ 2538.624694] [<c01ca934>] (hub_port_init+0x0/0x634) from [<c01cc404>] (hub_events+0x86c/0xe64)
[ 2538.624725] [<c01cbb98>] (hub_events+0x0/0xe64) from [<c01ce054>] (hub_thread+0x30/0x19c)
[ 2538.624755] [<c01ce024>] (hub_thread+0x0/0x19c) from [<c006da90>] (kthread+0x54/0x80)
[ 2538.624786]  r6:00000000 r5:c01ce024 r4:00000000
[ 2538.624816] [<c006da3c>] (kthread+0x0/0x80) from [<c005a950>] (do_exit+0x0/0x7bc)
[ 2538.624847]  r5:00000000 r4:00000000
[ 2538.624847] ---[ end trace 6fb00ab8cbf39d25 ]---
[ 2538.681732] usb 1-1: khubd timed out on ep0out len=0/0
[ 2538.891296] usb 1-1: device not accepting address 21, error -110
[ 2538.891387] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2538.891418] hub 1-0:1.0: state 7 ports 1 chg 0000 evt 0002
[ 2538.891448] hub 1-0:1.0: port 1 enable change, status 00000301
[ 2541.203796] hub 1-0:1.0: hub_suspend
[ 2541.203857] usb usb1: bus auto-suspend
[ 2541.203857] musb_bus_suspend 2266: trying to suspend as a_host is_active=1
[ 2541.203887] usb usb1: bus suspend fail, err -16
[ 2541.203918] hub 1-0:1.0: hub_resume
[ 2541.203979] hub 1-0:1.0: port 1: status 0301 change 0000
[ 2541.204010] hub 1-0:1.0: state 7 ports 1 chg 0002 evt 0000
[ 2541.204071] hub 1-0:1.0: port 1, status 0301, change 0000, 1.5 Mb/s
[ 2541.328948] usb 1-1: new low speed USB device using musb_hdrc and address 22
[ 2546.329010] usb 1-1: khubd timed out on ep0in len=0/64
[ 2551.328948] usb 1-1: khubd timed out on ep0in len=0/64
[ 2556.329040] usb 1-1: khubd timed out on ep0in len=0/64
[ 2556.453887] usb 1-1: device descriptor read/64, error -110
[ 2561.563293] usb 1-1: khubd timed out on ep0in len=0/64
[ 2566.563232] usb 1-1: khubd timed out on ep0in len=0/64
[ 2566.688171] usb 1-1: device descriptor read/64, error -19
[ 2566.860260] hub 1-0:1.0: port 1 not reset yet, waiting 50ms
[ 2566.922698] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2567.133575] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2567.344451] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2567.344451] hub 1-0:1.0: port_wait_reset: err = -16
[ 2567.344482] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2567.555419] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2567.766326] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2567.977996] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2567.978027] hub 1-0:1.0: port_wait_reset: err = -16
[ 2567.978027] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2568.188201] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2568.399169] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2568.610076] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2568.610107] hub 1-0:1.0: port_wait_reset: err = -16
[ 2568.610107] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2568.821014] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2569.032012] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2569.242828] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2569.242858] hub 1-0:1.0: port_wait_reset: err = -16
[ 2569.242889] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2569.453826] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2569.664703] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2569.875732] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2569.875762] hub 1-0:1.0: port_wait_reset: err = -16
[ 2569.875762] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2569.875793] hub 1-0:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
[ 2569.938201] hub 1-0:1.0: port 1 not reset yet, waiting 50ms
[ 2570.000701] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2570.211730] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2570.423522] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2570.423553] hub 1-0:1.0: port_wait_reset: err = -16
[ 2570.423583] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2570.633728] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2570.844635] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2571.055541] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2571.055572] hub 1-0:1.0: port_wait_reset: err = -16
[ 2571.055603] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2571.266571] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2571.477508] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2571.688262] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2571.688293] hub 1-0:1.0: port_wait_reset: err = -16
[ 2571.688323] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2571.899383] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2572.110229] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2572.321166] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2572.321228] hub 1-0:1.0: port_wait_reset: err = -16
[ 2572.321258] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2572.532073] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2572.742950] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2572.953857] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2572.953887] hub 1-0:1.0: port_wait_reset: err = -16
[ 2572.953887] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2572.953918] hub 1-0:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
[ 2573.016326] hub 1-0:1.0: port 1 not reset yet, waiting 50ms
[ 2573.078918] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2573.289825] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2573.501159] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2573.501190] hub 1-0:1.0: port_wait_reset: err = -16
[ 2573.501220] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2573.711883] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2573.922637] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2574.133636] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2574.133697] hub 1-0:1.0: port_wait_reset: err = -16
[ 2574.133728] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2574.289398] twl4030_usb twl4030_usb: HW_CONDITIONS 0xd0/208; link 2
[ 2574.320373] twl4030_usb twl4030_usb: HW_CONDITIONS 0x50/80; link 1
[ 2574.344451] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2574.555419] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2574.766448] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2574.766479] hub 1-0:1.0: port_wait_reset: err = -16
[ 2574.766510] hub 1-0:1.0: port 1 not enabled, trying reset again...
[ 2574.977294] hub 1-0:1.0: port 1 not reset yet, waiting 200ms
[ 2575.087768] Forced hostmode error: no device attached
[ 2575.189025] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2575.189117] hub 1-0:1.0: state 7 ports 1 chg 0000 evt 0002
[ 2575.189178] hub 1-0:1.0: port 1, status 0301, change 0003, 1.5 Mb/s
[ 2575.344573] hub 1-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x301
[ 2575.469604] usb 1-1: new low speed USB device using musb_hdrc and address 26
[ 2580.469573] usb 1-1: khubd timed out on ep0in len=0/64
[ 2585.469635] usb 1-1: khubd timed out on ep0in len=0/64
[ 2590.469696] usb 1-1: khubd timed out on ep0in len=0/64
[ 2590.594604] usb 1-1: device descriptor read/64, error -110
[ 2595.703918] usb 1-1: khubd timed out on ep0in len=0/64
[ 2600.704010] usb 1-1: khubd timed out on ep0in len=0/64
[ 2605.704010] usb 1-1: khubd timed out on ep0in len=0/64
[ 2605.829010] usb 1-1: device descriptor read/64, error -110
[ 2606.063476] usb 1-1: new low speed USB device using musb_hdrc and address 27
[ 2611.063385] usb 1-1: khubd timed out on ep0in len=0/64
[ 2616.063293] usb 1-1: khubd timed out on ep0in len=0/64
[ 2621.063385] usb 1-1: khubd timed out on ep0in len=0/64
[ 2621.188293] usb 1-1: device descriptor read/64, error -110
[ 2626.297729] usb 1-1: khubd timed out on ep0in len=0/64
[ 2631.297760] usb 1-1: khubd timed out on ep0in len=0/64
[ 2633.494964] twl4030_usb twl4030_usb: HW_CONDITIONS 0xd0/208; link 2
[ 2633.525970] twl4030_usb twl4030_usb: HW_CONDITIONS 0x50/80; link 1
[ 2634.405181] Forced hostmode error: no device attached
[ 2636.297576] usb 1-1: khubd timed out on ep0in len=0/64
[ 2636.360107] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2636.360137] hub 1-0:1.0: state 7 ports 1 chg 0000 evt 0002
[ 2636.360168] hub 1-0:1.0: port 1, status 0301, change 0003, 1.5 Mb/s
[ 2636.516357] hub 1-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x301
[ 2636.641357] usb 1-1: new low speed USB device using musb_hdrc and address 28
[ 2641.641448] usb 1-1: khubd timed out on ep0in len=0/64
[ 2646.641540] usb 1-1: khubd timed out on ep0in len=0/64
[ 2651.641510] usb 1-1: khubd timed out on ep0in len=0/64
[ 2651.766479] usb 1-1: device descriptor read/64, error -110
[ 2656.875701] usb 1-1: khubd timed out on ep0in len=0/64
[ 2661.875701] usb 1-1: khubd timed out on ep0in len=0/64
[ 2666.875640] usb 1-1: khubd timed out on ep0in len=0/64
[ 2667.001159] usb 1-1: device descriptor read/64, error -110
[ 2667.235198] usb 1-1: new low speed USB device using musb_hdrc and address 29
[ 2672.235137] usb 1-1: khubd timed out on ep0in len=0/64
[ 2677.235198] usb 1-1: khubd timed out on ep0in len=0/64
[ 2682.235931] usb 1-1: khubd timed out on ep0in len=0/64
[ 2682.360198] usb 1-1: device descriptor read/64, error -110
[ 2682.848480] twl4030_usb twl4030_usb: HW_CONDITIONS 0xd0/208; link 2
[ 2682.879516] twl4030_usb twl4030_usb: HW_CONDITIONS 0x50/80; link 1
[ 2683.536407] Forced hostmode error: no device attached
[ 2687.469573] usb 1-1: khubd timed out on ep0in len=0/64
[ 2692.469757] usb 1-1: khubd timed out on ep0in len=0/64
[ 2697.469665] usb 1-1: khubd timed out on ep0in len=0/64
[ 2697.532165] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2697.532226] hub 1-0:1.0: state 7 ports 1 chg 0000 evt 0002
[ 2697.532257] hub 1-0:1.0: port 1, status 0301, change 0003, 1.5 Mb/s
[ 2697.688293] hub 1-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x301
[ 2697.813415] usb 1-1: new low speed USB device using musb_hdrc and address 30
[ 2702.813415] usb 1-1: khubd timed out on ep0in len=0/64
[ 2707.813232] usb 1-1: khubd timed out on ep0in len=0/64
[ 2710.687561] Forced hostmode error: no device attached
[ 2712.813262] usb 1-1: khubd timed out on ep0in len=0/64
[ 2712.875701] Forced hostmode error: a full/low-speed device attached but high-speed mode selected
[ 2712.875823] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2712.875854] hub 1-0:1.0: state 7 ports 1 chg 0000 evt 0002
[ 2712.875885] hub 1-0:1.0: port 1, status 0101, change 0003, 12 Mb/s
[ 2713.031951] hub 1-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x101
[ 2713.094757] Forced hostmode error: a full/low-speed device attached but high-speed mode selected
[ 2713.156921] usb 1-1: new full speed USB device using musb_hdrc and address 31
[ 2718.157135] usb 1-1: khubd timed out on ep0in len=0/64
[ 2723.157104] usb 1-1: khubd timed out on ep0in len=0/64
[ 2728.157196] usb 1-1: khubd timed out on ep0in len=0/64
[ 2728.219512] Forced hostmode error: a full/low-speed device attached but high-speed mode selected
[ 2728.282012] usb 1-1: device descriptor read/64, error -110
[ 2733.391357] usb 1-1: khubd timed out on ep0in len=0/64
[ 2738.391510] usb 1-1: khubd timed out on ep0in len=0/64
[ 2738.453857] Forced hostmode error: a full/low-speed device attached but high-speed mode selected
[ 2738.516601] usb 1-1: device descriptor read/64, error -19
[ 2738.688262] Forced hostmode error: a full/low-speed device attached but high-speed mode selected
[ 2738.750854] usb 1-1: new full speed USB device using musb_hdrc and address 32
[ 2738.813415] Forced hostmode error: a full/low-speed device attached but high-speed mode selected
[ 2738.875976] usb 1-1: device descriptor read/64, error -19
[ 2739.047760] Forced hostmode error: a full/low-speed device attached but high-speed mode selected
[ 2739.110382] usb 1-1: device descriptor read/64, error -19
[ 2739.282012] Forced hostmode error: a full/low-speed device attached but high-speed mode selected
[ 2739.344573] usb 1-1: new full speed USB device using musb_hdrc and address 33
[ 2739.766448] usb 1-1: device not accepting address 33, error -19
[ 2739.828979] Forced hostmode error: a full/low-speed device attached but high-speed mode selected
[ 2739.891601] usb 1-1: new full speed USB device using musb_hdrc and address 34
[ 2740.313323] usb 1-1: device not accepting address 34, error -19
[ 2740.313415] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2740.313446] hub 1-0:1.0: state 7 ports 1 chg 0000 evt 0002
[ 2740.313476] hub 1-0:1.0: port 1 enable change, status 00000101
[ 2742.313323] hub 1-0:1.0: hub_suspend
[ 2742.313415] usb usb1: bus auto-suspend
[ 2746.398284] Forced hostmode error: no device attached
[ 2746.398376] usb usb1: usb resume
[ 2746.414825] hub 1-0:1.0: hub_resume
[ 2746.414947] hub 1-0:1.0: port 1: status 0301 change 0001
[ 2746.524261] hub 1-0:1.0: state 7 ports 1 chg 0002 evt 0000
[ 2746.524353] hub 1-0:1.0: port 1, status 0301, change 0000, 1.5 Mb/s
[ 2746.649200] usb 1-1: new low speed USB device using musb_hdrc and address 35
[ 2751.649261] usb 1-1: khubd timed out on ep0in len=0/64
[ 2756.649444] usb 1-1: khubd timed out on ep0in len=0/64
[ 2761.649200] usb 1-1: khubd timed out on ep0in len=0/64
[ 2761.774169] usb 1-1: device descriptor read/64, error -110
[ 2766.883697] usb 1-1: khubd timed out on ep0in len=0/64
[ 2771.883697] usb 1-1: khubd timed out on ep0in len=0/64
[ 2776.883789] usb 1-1: khubd timed out on ep0in len=0/64
[ 2777.008575] usb 1-1: device descriptor read/64, error -110
[ 2777.242980] usb 1-1: new low speed USB device using musb_hdrc and address 36
_______________________________________________
maemo-users mailing list
maemo-users@xxxxxxxxx
https://lists.maemo.org/mailman/listinfo/maemo-users

[Nokia N800]     [Home]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]    [Yosemite Photos]    [Video Projectors]     [PDAs]     [Free Online Dating]     [Hacking TiVo]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Devices]     [Big List of Linux Books]     [N900 Unlocked]

Add to Google Powered by Linux