[PATCH 0/5] acpi_power_meter: clean up duplicate code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

From: Kyle McMartin <kyle@xxxxxxxxxxx>

acpi_power_meter currently duplicates a lot of code between the rw and
ro sensor templates unnecessarily. The attached five part series cleans
things up to use the same code path for both, deciding which is which by
the use of the .set field.

Additionally, (imho at least) it makes the struct initializers a bit
more pretty and uses a macro to reduce the repetition of each member.

It's been compile tested across the series for bisectability, but I do
not currently have access to any device which uses this driver for

regards, Kyle McMartin

Kyle McMartin (5):
  acpi_power_meter: use the same struct {rw,ro}_sensor_template for
  acpi_power_meter: use a {RW,RO}_SENSOR_TEMPLATE macro to clean things
  acpi_power_meter: remove duplicate code between
  acpi_power_meter: drop meter_rw_attrs, use common meter_attrs
  acpi_power_meter: clean up code around setup_attrs

 drivers/hwmon/acpi_power_meter.c |  165 +++++++++++++++++---------------------
 1 files changed, 72 insertions(+), 93 deletions(-)


lm-sensors mailing list

[Video for Linux]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Photos]     [Yosemite Photos]     [Free Singles Community]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]

Add to Google Powered by Linux