|[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]|
Ingo Molnar wrote:
Small detail, the syntactic form you chose: + if (!cpu->arch.idt[num].p)is not very readable because it's not obvious at first sight that ".p" intends to mean "present bit". If then idt[num].present would have been the better choice - but it's even better to not do bitfields at all but an idt_present(desc *) helper inline function.
There is, however, some benefit to use the field names that are in the official documentation, which include P.
-hpa -- To unsubscribe from this list: send the line "unsubscribe linux-x86_64" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html