Search Linux Wireless

Re: [PATCH v2] compat: Define include guard for vga_switcheroo.h

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


> How about just adding this file but with something like this:
>
> #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,34))
> /*
>  * XXX: The include guard was sent upstream, drop this
>  * once the guard is merged.
>  */
> #ifndef LINUX_VGA_SWITCHEROO_H /* in case this gets upstream */
> #include_next <linux/vga_switcheroo.h>
> #ifndef LINUX_VGA_SWITCHEROO_H /* do not redefine once this gets upstream */
> #define LINUX_VGA_SWITCHEROO_H
> #endif /* case 1 LINUX_VGA_SWITCHEROO_H
> #endif /* case 2 LINUX_VGA_SWITCHEROO_H
> #endif /* (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,34)) */

Ah, that is much clever, thanks.

I've tested in and it works correctly, will send a v3. But just to
make clear: I'm just adding a vga_switcheroo.h with the above content
and I don't touch compat-3.5.h right?

-- 
Ozan Çağlayan
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux Kernel]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Photo]     [Yosemite]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]     [Free Dating]     [M2M Wireless]

Add to Google Powered by Linux