Search Linux Wireless

Re: wlan0 not present

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hmm, no one?

Am 22.04.2012 um 18:53 schrieb Emmanuel Grumbach:

> On Sun, Apr 22, 2012 at 16:00, Dominik Feser
> <dominik.feser@xxxxxxxxxxxxxx> wrote:
>> THX a lot! Here is the dmesg output:
>> 
>> Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:d
>> Copyright(c) 2003-2012 Intel Corporation
>> iwlwifi 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
>> iwlwifi 0000:02:00.0: setting latency timer to 64
>> iwlwifi 0000:02:00.0: pci_resource_len = 0x00002000
>> iwlwifi 0000:02:00.0: pci_resource_base = f4498000
>> iwlwifi 0000:02:00.0: HW Revision ID = 0x34
>> iwlwifi 0000:02:00.0: irq 1277 (277) for MSI/MSI-X
>> iwlwifi 0000:02:00.0: U iwl_request_firmware eebd9d74
>> iwlwifi 0000:02:00.0: U iwl_request_firmware c8ee1dd8
>> iwlwifi 0000:02:00.0: U iwl_request_firmware ed655dd8
>> iwlwifi 0000:02:00.0: d21d7e18
>> iwlwifi 0000:02:00.0: U iwl_request_firmware d21d7dd8
>> iwlwifi 0000:02:00.0: eda37e18
>> iwlwifi 0000:02:00.0: eda37de0
>> iwlwifi 0000:02:00.0: U iwl_trans_pcie_rx_free eda37d80
>> iwlwifi 0000:02:00.0: PCI INT A disabled
>> 
>> 
> 
> Still useless... Gosh... Does someone know to get real prints here ??
> I just use dev_err("WHATEVER %s", "STRING");
> 
>> 
>> 
>> Am 19.04.2012 um 18:19 schrieb Emmanuel Grumbach:
>> 
>>> On Thu, Apr 19, 2012 at 18:08, Dominik Feser
>>> <dominik.feser@xxxxxxxxxxxxxx> wrote:
>>>> May it be that the fact that Centos 5 doesnt have hotplug causes the issue?
>>>> 
>>> 
>>> Don't think so.
>>> Can it be a problem in the backport of request_firwamre_no_wait ?
>>> Did I see somewhere that you run 2.6.38 ?
>>> Can you check again after having applied the patch attached ?
>>> 
>>> from the main dir of compat:
>>> patch -p1 < print.patch
>>> 
>>> Thanks
>>> 
>>>> Am 19.04.2012 um 16:20 schrieb Johannes Berg:
>>>> 
>>>>> On 4/19/2012 7:09 AM, Dominik Feser wrote:
>>>>>> Finally, here is the output of dmesg after recompiling:
>>>>>> 
>>>>>> iwlwifi 0000:02:00.0: edd19e18
>>>>>> iwlwifi 0000:02:00.0: d55c1e18
>>>>>> iwlwifi 0000:02:00.0: d55c1ddc
>>>>>> iwlwifi 0000:02:00.0: PCI INT A disabled
>>>>>> Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:d
>>>>>> Copyright(c) 2003-2012 Intel Corporation
>>>>>> iwlwifi 0000:02:00.0: PCI INT A ->  GSI 17 (level, low) ->  IRQ 17
>>>>>> iwlwifi 0000:02:00.0: setting latency timer to 64
>>>>>> iwlwifi 0000:02:00.0: pci_resource_len = 0x00002000
>>>>>> iwlwifi 0000:02:00.0: pci_resource_base = f447c000
>>>>>> iwlwifi 0000:02:00.0: HW Revision ID = 0x34
>>>>>> iwlwifi 0000:02:00.0: irq 1277 (277) for MSI/MSI-X
>>>>>> iwlwifi 0000:02:00.0: U iwl_request_firmware d5b37d70
>>>>>> iwlwifi 0000:02:00.0: U iwl_request_firmware e09ebdd4
>>>>>> iwlwifi 0000:02:00.0: ee2afe18
>>>>>> iwlwifi 0000:02:00.0: U iwl_request_firmware ee2afdd4
>>>>>> iwlwifi 0000:02:00.0: cc93fe18
>>>>>> iwlwifi 0000:02:00.0: cc93fddc
>>>>> 
>>>>> Still pretty useless since you get %pV printed as a pointer rather than a message. Does anyone know how to fix that in compat? But the iwl_request_firmware 3 times probably means it failed?
>>>>> 
>>>>> johannes
>>>> 
>>> <print.patch>
>> 

--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux Kernel]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Photo]     [Yosemite]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]     [Free Dating]     [M2M Wireless]

Add to Google Powered by Linux