Re: [PATCH 7/9] usb: gadget: Add Android Composite Gadget driver

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Apr 23, 2012 at 01:36:23PM +0200, Andrzej Pietrasiewicz wrote:
> From: Mike Lockwood <lockwood@xxxxxxxxxxx>
> 
> The Android Gadget driver is a composite driver that allows
> userspace to change at runtime the list of functions enabled in
> its configuration and to configure these functions. It supports
> multiple functions: acm, rndis, mass storage and accessory.
> 
> It is usually controlled by a daemon that changes the configuration
> based on user settings. For example, rndis is enabled when the user
> enables sharing the phone data connection.
> 
> As an example on how to use it, the following shell commands will
> make the gadget disconnect from the host and make it be re-enumerated
> as a composite with 1 rndis and 2 acm interfaces, and a different
> product id:
> 
> echo 0       > /sys/class/android_usb/android0/enable
> echo rndis,acm > /sys/class/android_usb/android0/functions
> echo 2       > /sys/class/android_usb/android0/f_acm/instances
> echo 2d01    > /sys/class/android_usb/android0/idProduct
> echo 1       > /sys/class/android_usb/android0/enable
> 
> The driver requires a gadget controller that supports software
> control of the D+ pullup and the controller driver must support
> disabling the pullup during composite_bind.

This is a nice thing to have, but why call it "android_usb" when it
really is just a userspace configurable usb gadget driver?

And shouldn't you use configfs here instead of sysfs for this?

I'd really prefer a more generic name for this, given that lots of other
non-"android" people are going to be wanting to use this.

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux