Re: [patch] NFS: kmalloc() doesn't return an ERR_PTR()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]




Boaz Harrosh wrote:

  > Normally we wouldn't put an unlikely() here.  It makes the code
  > less readable and it's not going to affect benchmarks.  But I can
  > add one if people prefer.
  > 

  Personally It makes it more readable for me. It's like a statement:
  "error, always slow-path case here". I have brain parsers set
  for these.

Personally I don't like it.  It's a hint for the compiler.  Remember when
code was liberally sprinkled with "register" modifiers on local variables?
Turned out the compiler was smarter than we were, and those modifiers were
hurting performance.  I'd rather let the compiler decide how to optimize.
--
To unsubscribe from this list: send the line "unsubscribe linux-nfs" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux USB Development]     [Linux Media Development]     [Video for Linux]     [Linux NILFS]     [Linux Audio Users]     [Photo]     [Yosemite Info]    [Yosemite Photos]    [POF Sucks]     [Linux Kernel]     [Linux SCSI]     [XFree86]

Add to Google Powered by Linux