Re: Re: [PATCHv3-resend] atomic: add *_dec_not_zero
|[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]|
On Friday 17 June 2011 17:13:12 Arnd Bergmann wrote: > On Friday 17 June 2011, Sven Eckelmann wrote: > > Introduce an *_dec_not_zero operation. Make this a special case of > > *_add_unless because batman-adv uses atomic_dec_not_zero in different > > places like re-broadcast queue or aggregation queue management. There > > are other non-final patches which may also want to use this macro. > > > > Reported-by: David S. Miller <davem@xxxxxxxxxxxxx> > > Signed-off-by: Sven Eckelmann <sven@xxxxxxxxxxxxx> > > Acked-by: Mike Frysinger <vapier@xxxxxxxxxx> > > Acked-by: James Bottomley <James.Bottomley@xxxxxxxxxxxxxxxxxxxxx> > > Acked-by: David S. Miller <davem@xxxxxxxxxxxxx> > > Acked-by: Ingo Molnar <mingo@xxxxxxx> > > Acked-by: Jesper Nilsson <jesper.nilsson@xxxxxxxx> > > Acked-by: Ralf Baechle <ralf@xxxxxxxxxxxxxx> > > Acked-by: David Howells <dhowells@xxxxxxxxxx> > > Acked-by: Chris Metcalf <cmetcalf@xxxxxxxxxx> > > Acked-by: Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> > > Acked-by: Will Deacon <will.deacon@xxxxxxx> > > Acked-by: Matt Turner <mattst88@xxxxxxxxx> > > Acked-by: Benjamin Herrenschmidt <benh@xxxxxxxxxxxxxxxxxxx> > > Acked-by: Paul Mundt <lethal@xxxxxxxxxxxx> > > Acked-by: Heiko Carstens <heiko.carstens@xxxxxxxxxx> > > Acked-by: Hirokazu Takata <takata@xxxxxxxxxxxxxx> > > Cc: Tony Luck <tony.luck@xxxxxxxxx> > > Cc: Fenghua Yu <fenghua.yu@xxxxxxxxx> > > Cc: linux-ia64@xxxxxxxxxxxxxxx > > Cc: Arnd Bergmann <arnd@xxxxxxxx> > > Cc: linux-arch@xxxxxxxxxxxxxxx > > --- > > Nothing changed - only added the Acked-by from Hirokazu Takata. That > > means that I am still waiting for ia64 and Arnd Bergmann (maybe he wants > > to merge it in his tree?). > > Hmm, I didn't look at the first versions unfortunately. Remind me why we > don't just open-code the atomic_add_unless in batman-adv. Because some developers behind batman-adv and fault_inject thought that it is easier readable and David S. Miller said that it is a good idea to have something like it in atomic*.h Other places were it can be used: * drivers/media/video/omap3isp/ispstat.c * drivers/s390/net/qeth_core_main.c * fs/ext4/ext4.h * fs/xfs/linux-2.6/xfs_buf.c * mm/memcontrol.c * net/core/drop_monitor.c * net/phonet/pep.c > Since people apparently think that this patch is a good idea, I'll merge it > in the asm-generic tree once I understand why this is done. Don't feel pushed --- you can just say that you absolutely doesn't want it. I only tried to keep David happy, but don't want to start a fight over it. thanks, Sven
Description: This is a digitally signed message part.