Re: /proc/pid/fd/ shows strange mode when executed via sudo.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Fri, May 18, 2012 at 9:08 AM, Linus Torvalds
<torvalds@xxxxxxxxxxxxxxxxxxxx> wrote:
>
> I would suggest just moving the i_mode initialization from
> proc_fd_instantiate() into the revalidate function that we already
> have, and that already fixes up i_uid/i_gid etc. Attached is a TOTALLY
> UNTESTED patch that does this, and actually seems to simplify things
> in the process.

Ok, so it's now "tested" in the sense that it works for me, and fixes
both my and your test-cases.

Which doesn't mean that it is bug-free of course, but it does seem to
be a sane patch that actually cleans things up.

I'll delay committing it in case somebody hollers, but I think I'll
mark it for stable too since this issue seems age-old, and the fix
looks good.

Ack/nak? Can anybody find anything wrong in that patch?

                   Linus
--
To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux Ext4 Filesystem]     [Ecryptfs]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Photo]     [Yosemite]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [CEPH Filesystem]


  Powered by Linux